Cycles volume and transparent background

Hello everyone!
Is it possible to use cycles volume shading on a domain for smoke and fire and render it while using a transparent background?
When I try rendering my scene, the smoke and fire will only render when there is a background.
Here is an image for reference:

Does anyone have an idea how I could do this?
It does work when I uncheck “Transparent” in Rendersettings -> Film.

Thank you very much in advance,

If this information is needed, I am using Blender 2.71.

Ever figure this out? I can’t get any smoke/fire to render with transparent film turned on. not sure how to composite the result into anything without transparency…