Cycles Volume Pass

Since there is no default Volume Pass checkbox in Cycles yet I put together a compositor node group which just simply extracts it out of the beauty pass by subtracting diffuse, glossy and transmission component. To handle volume pass separately, blur it for example and than add it back without a noise can be rather time-saving.

Download Volume_Pass.blend (762 KB)

Hopefully it’ll be helpful to someone as it was to me!

I thought I heard of a workaround for getting this. I’m quite happy then that such a thing would not require rendering a completely separate version of the scene.


Thank you Paya! ^^ very usefull for me :slight_smile:

This sounded very useful so I gave it a go with your file. With a few blurs in compositing and using the separate vol pass what was a real noisy render ( You deliberately set it that way I figured) was easy to clean up quite a fair bit. This pass is going to be really useful.

Ive overdone the blur but those fireflies are gone LOL.

I need to figure out why the glass is not compositing correctly. Im doing something wrong obviously.

Tried to fix the glass and also took some of the blur down a bit. Same render settings as in your file.

Had another go. Still exactly your setup. removed fireflies as best I could just through compositing with bilateral blur. Added in sunbeams just because we can. Thanks again for this node group. I had fun trying to despeckle your intentionally noisey setup.