Cycles weird noise artifacts

So I got this new GPU today and made a quick wine bottle to try the cycles GPU rendering, well have to say it’s awesome!
But in viewport rendering was fine and looked great, whilst acctually rendering it made these weird artifacts appear.

Here’s in the viewport after about 100 samples;

And here’s when its rendered; first image is the first couple of samples the second, after 600:

So now I’m wondering, how do I solve this problem? And why is the viewport so much diffrent than the render?

/Thanks in advanced, Eric

And the shader for the glass;

i dont have an answer for you, but i was also getting weird results glass
(viewport render as opposed to actual render, Even when my viewport render was looking though the perspective of the camera
it was still a different result from what it actually rendered)

My problem was a lightbulb.(it was rendering transparent in the VPR where i could see the filiment, but in the FR"Final Render"
the glass wasn’t transparent it was white and glossy)

I believe i did something similar to you and used the mixshader with the glass i wonder if thats part of the problem…

try just using regular glass(no mix glossy) see if that calms it down.

i think i might have found your problem…

Look and see if you have any object in the scene with the visibility
disabled in the outliner(eyeball)“restrict visibility in viewport”

I have a feeling you have doubled up geometry, with one “restricted visibility” and the other visible…
IF so… Click the Camera and “restrict renderability” next to it as well…
(that should fix this!, if its not visible it shouldn’t render IMHO) wow…

thats what was wrong with my lightbulb, i just went back to it…
it was rendering fine in the viewport, but when you render it opps!!!

Cycles “final render” will render objects even if viewport visibility is disabled on them(you need to restrict renderability, to disable them)
Viewport render works differently.