Cycles-World-Voronoi material override problem

Hi everyone,

I found this nice tutorial, helping in creation of starfield in cycles:

Looks like some other node setting works better, but it’s not the issue.
Problem is, when I set up World settings, every object in my scene goes black - like the background texture would override all other settings of the objects.

Any help?

Thank you in advance.
Marian

Not exactly tutorial… Hope helps.
http://www.pasteall.org/blend/19054

Do you have any light source in scene other then background? As that star background become nearly black and make all scene black.

I did set camera to the same range; picture is a bit, ehrmm… too pixely… One way to correct that would be a little post composit; see if this helps. http://www.pasteall.org/pic/45682

Thanks, that’s much better!