Cylces particles system's material settings not working?

Hi,

I use Blender 2.68a and cycles.
I have a simple plane and added a particle system of type hair to it.
(I activated the experimental features inside the ‘Render’ properties panel).
Then I created two materials Mat1 and Mat2.
I want to render tha plane (emitter) with Mat1 and the particles (strands or hair) using Mat2.
So I went to the particle system settings and changed the material inside the render section to Mat2
But always the hair renders with Mat1 (that one from the emitter) even if I change it to Mat2.

What I am doing wrong? Can I render different materials for emitter and particles or is it just not supported yet for cycles?

One more question, if I disable ‘Emitter’ (to avoid rendering the emitter) the emitter is still rendered - why?

Thanks for any information!

Can I render different materials for emitter and particles or is it just not supported yet for cycles?
Yes, works correctly for me.


if I disable ‘Emitter’ (to avoid rendering the emitter) the emitter is still rendered - why?
Works correctly for me.

If you are using your gpu to render, try changing to cpu
Attach or post a link to your blend file so we can see your scene and settings

Hi Richard,

thanks for reply. I even thought it should be easy but for some reason it does not work :(.
I don’t use GPU but CPU.


I use the default scene, set Render to ‘Experimental’, created two materials Cube and Hair.
Then I added a particle system of type hair and switched Material to Material 2
In the 3D view one can see that cube and hair have different material, but the render does not.

The .blend-file I attached as well.

Thanks for further help!

Attachments

hairtest.blend (865 KB)