cyrillic charackters support in Blender?

Hi, I am new to Blender and today I noticed that I cannot input text using cyrillic charackters (bulgarian). The cursor just stays. Latin text is fine.
I wanted to make a 3d logo. So I typed the text in Gimp and now I am tracing the charackters with the bezier curves :frowning:
Is there a better way?
I am using unicode fonts, that are working perfectly with Gimp.
I am on Linux, Fedora Core 3

I have tried windows using Arial with Kazak and it worked before. Some of the other unicode fonts didnt include the Kazak letters. I just tried it again and it didnt work. I am using a one of the newer test builds for windows.

Looks like some stuff has been added nice things like modifiers(curve, lattice, etc) Havent tried this out on the test build yet.

But here is what you can do if you are using 2.41. Set your font to a unicode font. And text spacebar, then click on the char tab. Then on the unicode table button then select cyrillic, you should see a table of letters that you can input in the text you want.
Hope this helps

I am using 2.37 and can’t see this char tab. May be it doesn’t exist prior to version 2.41? Does that have anything to do with the user prefs -> fonts -> international fonts? (it is off, I haven’t modify my user preferences)

Or you could just write some of those letters in a graphic program and use them as blueprints. That’s how I did when I didn’t knew the ALT+C function.

Looks like 2.4 had some great updates to the text tool. http://mediawiki.blender.org/index.php/Release_Notes/Text
I think that 2.41
Some of the test build have further improvements modifiers.
I would recommend downloading at least 2.41 for the logo.

Or for a step by step, see this Tutorial by Broken: https://blenderartists.org/forum/viewtopic.php?p=431446#431446

This tutorial worked for me. :smiley: However, I should point out that I had to change open/save file settings to “UnicodeUtf8” in my text editor for it to work. I used the Kate advanced text editor in Linux. So this proves it works on Linux. So then I went to Ruski site, copied and pasted the Ruski text into Kate. Very easy.

Very important Petersk, like Ibkanat said, you need to get the latest Blender version for this to work.

Also you need to get a Unicode ttf Ruski font, I found the lsansuni.zip font at http://www.orwell.ru/test/download/ this worked fine for me. Or you can google your own.

O.K., now I am downloading the 2.41 source code… I will have it installed in minutes!

Thanks for your help!!!

Peter