Dark Edge Around Hole

So I’ve been trying to make a hole through a round object, and I seem to have succeeded more or less. Only a problem: the edge of the hole on the outside of the object is shaded. This is not what I want; specifically, I want for the surface of the object to appear completely smooth and uninterrupted, save for the sudden edge of the hole. I’ve tried creasing the edge, but nothing works. Here is a picture of what I’m talking about.

http://www.kirbot.com/linked/blender/dark_edges.jpg

I am not using any Subsurf modifiers, or any modifiers for that matter. I’ve set Smooth on the object as a whole, which I suspect is what’s causing it. Unfortunately, I don’t know how to make it see that edge as being sharp. Selecting the faces around the edge and setting to Flat gets rid of it, but then makes each face appear flat.

Does anyone know how to fix this?

In Edit Mode, select the edges of the borders of that hole
http://i.imgur.com/oSSig.jpg

press CTRL+E then “Mark Sharp” (or Mesh -> Edge -> Mark Sharp)

Then back to Object Mode
http://i.imgur.com/4Rmv8.jpg

Add an Edge Split modifier, uncheck “Edge Angle” and leave “Sharp Edges” checked, so it will make the edges you marked as sharp becoming sharp
http://i.imgur.com/TG9nt.jpg

In Edit Mode, you can select more edges and mark them as sharp, as long as you have the Edge Split modifier active, each of these edges will become sharp visually
http://i.imgur.com/r09AQ.jpg
http://i.imgur.com/y5BE8.jpg

note : to see the edges you marked as sharp in edit mode being slightly colored with blue, while in Edit Mode press N to bring the right panel of the 3D view, scroll down to “Display” and check “Sharp”

That is exactly what I was looking for. Thank you!