Dark lines on Cycles render

I’m doing some rendering with a rig I’ve been using in an animation, but for some reason in a couple of close up shots, I’m getting dark lines on the character’s mask.

I’ve been trying everything I can to find the cause, but no luck so far. it’s only evident in a couple of shots, and I can’t replicate the issue in the library file I’m linking in, even when I replicate the scene lighting in that file (1 sun and high res HDR environment texture).

the only thing that’s helped a little is upping the subsurf level, but it doesn’t fix the problem completely.

Here’s an example with simplify/no subsurf on:

and here with susurf up to level 5 - still got black lines across the eye sockets:

I’ve tried:

  • Looking for object double ups and doubled geometry
  • hiding every other object in the scene one by one
  • Removing fresnel from the material
  • lightly scuplting the eye sockets (this made some change, maybe, but I don’t want to change the shape really)
  • In the render passes, checking diffuse and glossy, direct and indirect. Lines appear in all passes to some degree
  • removing Normal Maps from material
  • adding a mask modifier to hide the head under the mask
  • probably other things I can’t think of right now…

I’d be so grateful if anyone knows what this could be, or would have a look around my character .blend to see if you can spot something. The group I’m linking to my scene in this case is GrpKing btw.


But as I say, the weirdest thing is that I can’t get those lines to appear at all in the library file. Only in the scene file I’m linking it into. :confused:

Here’s a screeny of my outliner. Hard to post the scene blend as it’s a giant web of linked files and textures. Thanks so much for looking :slight_smile:

Don’t have time to check your blend, but you should try to switch from Dynamic BVH to Static BVH (in Render settings - Performance). Maybe it helps :slight_smile:

I opened my default blend in 2.73a (two mesh lights and ibl jpeg), and linked in the 3 king groups, and it rendered perfectly. What version you using? It must be a settings/version issue. The only thing I see possibly off with the nodes on the mask is you probably want to feed the normal noodle into the fresnal node. But that has nothing to do with the lines.

Thanks for the replies guys. @Photox, I have the same issue. The rig renders fine in most scenes and in the king rig file, just not in a couple of shots I’ve linked it into. Very weird. I’m using 2.73a, and have tried it in 2.72 with the same result. And I did have that normal map feeding the fresnel, but disconnected it as part of my scattershot fault-finding :slight_smile:

I’ll definitely try Dynamic/Static BVH to see if that helps, and I’m downloading the 2.74rc to see if that’s any different. Will post back with my results.

If that doesn’t help, I’ll do try to post a stripped back version of my scene to look at.

OK I tried 2.74rc1 and Switching from Dynamic to Static BVH, but no luck either way.

Any other ideas welcome, while I try to sort out a scene blend for you to look at. Cheers.

Maybe a placement or a scale problem?
If a object is too far away from the center or too small then this could be the reason.

@JoHal Vielen Dank! I will definitely try this, as in my scene the rig is placed a long way off the origin I think. Will report back as soon as I’ve tested.

Danke Schön, grazie mille and thank you. Problem solved!

I wonder if this should be logged as a bug, or am I expecting too much to be able to move objects 700m from the origin :eyebrowlift2: :smiley:

I think it is a problem in CG in general.
I had the same issues in Lightwave a couple of years ago.
Maybe a dev can explain this better.