DAZ Importer

Hello @ThomasL :slight_smile:

I’ve probably did something wrong but the mesh seems to not following the armature / bones anymore… The last things I did was to change the body mass of the female body because my attention was to attach a camera on follow path to track the eyes instead of the middle of the mass body… Something else I’ve noticed, lashes and eybrows are seperate rigs and I’ve merge them on diffeomorphic adddons but now the riggs seems not attached to the body anymore too !
Another strange things I’ve notice is that my mesh seems now to have sharp edges even in render view…



Lashes and eyebrows have separate armatures because that is how they are defined in DAZ Studio. The importation step gives you what you have in DS, and the other tools let you change that into something which is more useful in Blender.

I noticed that you have merged all rigs to the Lashes rig; the collection containing the meshes is called Lashes meshes. When you use the Merge Rigs tool, the body rig should be the active object, so you merge the lashes and brows rigs to the body rig. The mesh collection will then be called Monique 8 classes.

1 Like

Ok this is driving me insane.

Did an Easy Import:

I import the necessary custom morphs I want into the geograft. I can see the morphs in the shapekeys for the geograft.

Now I want to merge the geograft.

So I have the geograft selected.

I shift+selected the figure’s body.

I go into Finishing > Merge Geografts (1.6.0.0559)

And get the following:

image

Does anyone have any thoughts?

Hi mjc3d,

try using the latest build from the bitbucket account.

Thank you for the suggestion.

I actually tried that last night!

It didn’t work. :frowning:

image

I think I found the problem. Posting this in case it helps someone else out.

I basically did a test going through all the options and I narrowed down the problem to the Merge Lashes option.

I guess something happens when Merge Lashes is enabled because if that option is checked you can’t go in and Merge Geografts later.

To recap, if Merge Lashes is checked on Easy Import, it prevents you from manually going-in and Merge Geografts from the Finishing section later. You will get an error message of:

ERROR: No geograft selected.

Merging geografts relies on vertex numbers, so it will not work if you have done anything that changes those. Like editing the mesh (add or remove vertices), merging other geografts, or joining other meshes like eyelashes.

That said, it would in fact be possible to merge geografts after meshes have been joined, since the joined vertices are added after the original ones, so the original vertex numbers are still intact. At least that could be done during easy import, where the situation is fully controlled. I will see if I can implement that.

Alternatively, the plugin could refuse to merge lashes if the character has geografts and merge geografts is unchecked. But that would also be confusing.

1 Like

What if you made it so that during Easy Import if you clicked on Merge Lashes it automatically un-checked Merge Geografts? (And vice-versa: selecting Merge Geografts unchecks Merge Lashes).

I don’t think that would be very confusing (for long). I think for the first 30 seconds someone might be confused as to why when checking one disables the other, but I think then it would become pretty obvious why.

Ok, now I have another weird problem!

The “shaft1” bone of Dicktator won’t rotate on any axis.

“shaft2” through “shaft7” bend/ rotate just fine.

I looked and I have no bone constraints for the shaft1 bone.

Also the transform parameters aren’t locked.

Does anybody have any ideas how to make that one bone be able to be rotated?

The problem should no longer arise. It not possible to check or uncheck boxes in the draw function, so the Merge Lashes option is ignored if there are unmerged geografts. So if Merge Lashes is enabled, the lashes are actually merged if either

  1. Merge Geografts is enabled, or
  2. The character has no geografts.

This may be confusing, but at least nothing is irreversibly ruined during easy import.

2 Likes

You have loaded some morphs which drive the shaft bone; that’s why the rotation and scale channels are purple. If you both want to use the morphs and rotate the bones manually, you need to Make All Bones Poseable. This must be done before the rig is converted to Rigify.

2 Likes

Oh! Thank you. I misunderstood what “Make All Bones Poseable” meant.

Just out of curiosity is there a reason why we join the eyelashes to the figure instead of parenting the eyelashes (with Follow Transformations)?

PLEASE HELP ME

The plugin works well except while converting the rig to MHX. Every JCM works, but not in the wrist and ankle when flexing de IK bone. The driver only recognice the tweak bone, so if you want to pose using IK the JCM doesn’t work. Please how can I fix this? Maybe creating a new driver for the IK but I couldn’t figure out the step by step to do this

It’s the same for any figure, you can reproduce the error just converting any rig to MHX

Solved by the Author here:

Is there a way I can keep the metarig when selecting “rigify” option on importing a daz character into blender? the rig is close to perfect but it needs to be adjusted for some bones and the only way you could do that is through the metarig which for some reason is deleted in the import process…

Use the two buttons below Convert To Rigify to do the conversion in two steps.

  1. Create Metarig.
  2. Tweak the metarig as you like
  3. Rigify Metarig.

metarig

2 Likes

i tried that method but my metarig doesnt come out as good and in my experience has even more problems then the automated one (this is simply because im not a good rigger) . i was wondering if it were possible to import with automated rigify rig but still keep the metarig. also it doesnt create face rig that is done really well in the automated one

Workflow for Dicktator/ Futalicious

Is there a workflow documented for loading up the custom morphs for Dictator/ Futalicious?

I’ve gone through the “Load Custom Morphs” and most of the morphs work but for example the Foreskin morphs don’t seem to work for some reason.

I tried setting all foreskin morphs I could find under Custom Properties to a value of 1.0 and nothing is happening with the foreskin in either Dicktator or Futalicious.

When I use Save Pose Preset to save an action to a Pose Preset file and then load it in Daz, the armature rotation is off.

I think the rotation in Daz is off because it is saved as XYZ Euler when saved.

When I load the pose preset file into Blender and change the armature rotation from ZXY Euler to XYZ Euler, the pose now matches the original.

I would like to have the same display on the Daz side as in Blender, so please allow me to save it as ZXY Euler.

1 Like