DAZ Importer

I’ve been using your add-on with 2.81. I uploaded the base Generation 8 Female.
Just curious, and I’m assuming you have, but did you try to bend the fingers using the controllers after Rigify the character? Or do you just observe the axis direction? After rigifying the axis will be pointed correctly, but bend improperly.

I haven’t tried it with 2.8 since 2.81 has been working great, and since I found a workaround for the issue.

Funny note on my workaround: After correcting the roll, it shows “X” to be the axis for the inward curl, but “Y” is what’s needed.

Thanks again for this add-on and thanks big time for the very detailed documentation that you provide. The later is invaluable.

This I don’t understand. Y is always pointing along the bone in Blender.

I’m having trouble with the importer. Unfortunately it seems to have an issue with some geografts. I am using Meipe’s geograft addons, specifically the Golden Palace and the newer Breastacular. I have had no real issues exporting with the Golden Palace, but when I tried exporting with both that and the Breastacular geograft on my G8F character, the script failed and spat out an error:

Traceback (most recent call last):
  File "C:\Users\~\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\import-daz\daz.py", line 51, in execute
    getMainAsset(self.filepath, context, self)
  File "C:\Users\~\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\import-daz\main.py", line 86, in getMainAsset
    asset.build(context, inst)      # Builds armature
  File "C:\Users\~\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\import-daz\light.py", line 82, in build
    self.material.build(context)
  File "C:\Users\~\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\import-daz\light.py", line 253, in build
    self.light.data.use_nodes = True
AttributeError: 'NoneType' object has no attribute 'use_nodes'

location: <unknown location>:-1

Any ideas? I need to get this working properly with the geografts, for my projects…
Actually, it might be the lights. I’ll try deleting them, then try again.

edit: There aren’t any lights in my scene, at least not when I exported it.

Hiding every geometry-shell in DAZstudio before using the importer (hiding, not deleting) seems to do the trick for me sometimes.

Hmm. Right. Hidden, but they will still export… I’ll have to try that here soon.

Thanks.

The offending line has been removed in the development version. I rarely have lights in my scenes, so this code hasn’t been checked for a long time if ever.

This is, imo, one of the most impressive & useful Blender addons out there at the moment (and the fact that its free is crazy!). Great job!
I’m having one minor issue, though, after I convert the rig to Rigify: Basically, when I move the foot IK controller, the leg bends in a very strange way (pics below). Is anyone else having this problem? Any idea how to fix it?

It looks like you didn’t optimize pose for IK. It’s an option under the finishing tab in the add-on.
The add-on orders the steps (from top to bottom) needed to take after import to optimize the character in Blender.

The author of the add-on added great documentation, and it’s well worth the time to follow along while doing your first few imports.

Thanks, that definitely seems to help. It doesn’t quite eliminate the problem entirely, but I imagine I can further tweak the pose manually and apply it as the rest pose before converting. Just one more quick question: When a new rest pose is applied, will this adversely affect the JCMs (I’m not sure whether they are dependent in some way on the default rest pose)?

Yeah, I have to do some minor bone tweaking here and there but nothing crazy, and only to fit my taste of movement.

I don’t believe a change like that will effect anything in a negative way, but I’m not positive. Maybe @ThomasL could answer this better.
Every tweak I’ve made hasn’t broken the rig, morphs, or correctives.

The changed rest pose probably affects JCM’s involving thigh and shin rotation, but I don’t know how much. It definitely adversely affects loaded poses. But then again, there are other modifications that do that too, e.g. if the character wears high heels.

Thanks for the reply! Just one more quick question: Do you think it would be technically feasible for the “Apply Rest Pose” function to automatically adjust currently loaded JCMs and poses to compensate for the new rest pose?
(I don’t intend this as a criticism of your addon, by the way… I think you’ve done an amazing job! I’m just wondering if such a feature would even be possible)

Yes, it should be relatively straightforward. One needs to add the change in vertex locations to each shapekey, and then change the drivers to reflect the new bone orientations. I’m putting it on my to-do list.

2 Likes

I would like to import the face units and use them as Shape_keys for game engine export purposes.

How do I go about this? Right now it’s imported as “drivers” or something inside the Importer, but it’s useless to me.

I want to be able to use those morphs on Unity to make expressions and such.

For Genesis and Genesis 2 characters, facial expressions are shapekeys. By default they are driven by a rig property, but you can change that by turning off Add Face Drivers in the Rigging section of the Settings panel.

In Genesis 3 and 8, a facial expression is a pose of the face rig. In this case the driver is all there is to the morph. You cannot easily convert such a morph to a shapekey, since no shapekey was defined in the first place.

I understand. It’s a bit complicated lol.

I managed to work around this by using the [ Edit Export Morphs Rules ] button in Daz’s FBX exporter.

I added things like “eCTRLE” for the eyes controls, “eCTRLM” for the mouth controls, etc. set them to export instead of bake and it exported all of them as Shape_keys.

After a bit of experimenting and cleaning up in Blender, everything seems to be okay. Let’s hope everything goes well.

Thank you, Thomas for your answer, though. I appreciate you taking your time.

1 Like

Did you fix the hair converter for 2.8?

Hey thought I would mention in Blender 2.8 the Daz Import Settings tab ends up in the sidebar (N key)

Took me a bit to set my Daz location as I was trying to find the settings tab in the old blender layout.

Does anyone know how to force DAZ importer to pick the LOD I want from DAZ? For some reason it completely ignores my low res in DAZ even after I set it in the mesh res panel. It always imports with the highest res available. Any ideas?

I’m running into the same issue. I am not sure what you mean by correct the roll. What should it be set at? I can’t seem to figure out how to make my fingers not go all over the place.