DAZ Importer

I forgot to tell you that I didn’t use Geometry Editor in DAZ before exporting.
I don’t know anything about this tool from DAZ 3D and I don’t understand how it works (if anyone can explain to me…).
I only noticed that when it is applied, the geograft takes on the G8M texture!
patrickp78

Hi @ThomasL , I’m having an issue with hair conversion in the latest 1.5.1 development build. Some of the particle hair systems only partially react to Hair Dynamics. In the following image, only the front side bangs are affected by hair dynamics whereas the rest of the hair is perfectly frozen.

I’ve set pin strength to zero as well as attempted weight painting that section to the lowest strength and it continues being unaffected by Hair Dynamics.

Do you have any ideas on how to resolve this? I’ve looked at your documentation to see if there’s anything to help with this, as well as searched for general Blender hair system trouble shooting but I’ve yet to find any solutions.

Thanks!

I’m just messing around/experimenting and trying to import a scene that has a lot of stuff in it that I probably have no business trying to import and am receiving this error.

File “C:\Users(username)\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\Diffeomorphic-import_daz-21fca95f8bad\geometry.py”, line 878, in repr
return ("<Uvset %s ‘%s’ %d %d %s>" % (self.id, self.name, len(self.uvs), len(self.polyverts), self.material))
AttributeError: ‘Uvset’ object has no attribute ‘uvs’

Is there anyway to determine what the offensive geometry is?

The interesting information is what happened before. The plugin is trying to write an error message, but there was a bug in the code that does that. With the latest commit [9fcc2ce] the interesting error message should be printed correctly.

1 Like

Cool I’ll update and play with it some more when I put a dent in some of my school projects. Burnout is a real thing right now.

Hello!

I was wondering if anyone had success in converting EXPRESSIONS into bones?

Right now I can import the expressions as shapekeys, but I need them as animated bones.

Is there a way to do it? Even if it doesn’t require Daz Importer?

It’s a going to depend on how those expressions are applied in DAZ. If the expression is a pose it should use the existing bones, if it is a morph, it would be a shapekey. If I recall correctly.

School had had me really busy for a while. So I am severely ignorant when it comes to this stuff right now.

But if you need to use bones, then I would suggest going through the documentation on importing poses, and be sure to use expressions that are poses(use bones) in DAZ. I believe this is one of the reasons for the new Genesis 8.1 facial rig stuff.

One thing I am having a hell of a time getting to work right now is importing custom poses for geografts. I’m still messing with it b/c I haven’t done my due diligence to rule out my own stupidity from being the problem.

Update
Started figuring it out. What you save as a pose preset in Daz can apparently be a mix between Shapes, Morphs. and Actual bone posing. Which makes for some seriously confusing stuff on the blender side of things. Well back into the Abyss with me.

DAZ Importer Version 1.5.1 released

There has been lots of progress since version 1.5.0 of the DAZ Importer was released half a year ago, and it is time for a new stable release. Among the highlights of the new release we mention:

  • Hair improvements, both for fibermesh hair, strand-based hair, and old-fashioned mesh hair.
  • Geometry shell improvements.
  • Faster transfer of morphs between meshes.
  • Improvements to the MHX rig.
  • Improvements to the Rigify interface.
  • Support for FACS introduced in DAZ Studio 4.15.
  • Many bug fixes.

Stable version 1.5.1 can be downloaded from https://www.dropbox.com/s/dvw2589ld1x07e0/import_daz-v1.5.1-20210227.zip.

As before, the development version can be downloaded from: https://bitbucket.org/Diffeomorphic/import_daz/downloads/

This is the last version that is compatible with Blender 2.79. Future versions of the DAZ Importer, from version 1.6.0 and forward, will only work with Blender 2.80 and later. Maintaining compatibility with Blender 2.79 has become a major nuisance, and since I suspect that very few people use it these days anyway, this means a lot of work for very little gain. Critical bugfixes can still be done in the version_1_5_1 branch, which can be downloaded from https://bitbucket.org/Diffeomorphic/import_daz/downloads/?tab=branches.

Acknowledgements:

Although the code has been written by myself, this add-on has benefitted greatly from bug reports and suggestions by many people. In particular, I want to thank

Alessandro Padovani, for his expertise in materials. The translation from Iray to Cycles and Eevee is essentially Alessandro’s achievement.

engetudouiti, for his suggestions in many areas, especially rigging.

Xin, for his lucid explanations on coding and the Blender API.

5 Likes

I was going to edit the first post in this thread to include the new version, but for some reason BA doesn’t let me edit it anymore. Weird.

@bartv any thoughts…?

That’s correct - you have a limited amount of time to edit your posts, it’s an anti-spam measure (we had quite a bit of spam where spammers would post something legit, then come back a few weeks later to add spam links). This is the way Discourse handles it, we’re thinking about alternatives.

1 Like

@ThomasL .

Hmmm…Started to get this error in Blender 2.92…Using the 1.51 latest version

Python: Traceback (most recent call last):
File “F:\Temp\Blender-2.92+\2.92\scripts\addons\import_daz\error.py”, line 246, in execute
self.run(context)
File “F:\Temp\Blender-2.92+\2.92\scripts\addons\import_daz\daz.py”, line 47, in run
getMainAsset(self.filepath, context, self)
File “F:\Temp\Blender-2.92+\2.92\scripts\addons\import_daz\main.py”, line 66, in getMainAsset
main = parseAssetFile(struct, toplevel=True)
File “F:\Temp\Blender-2.92+\2.92\scripts\addons\import_daz\files.py”, line 335, in parseAssetFile
return asset.parse(struct)
File “F:\Temp\Blender-2.92+\2.92\scripts\addons\import_daz\files.py”, line 115, in parse
inst = asset.makeInstance(self.fileref, nstruct)
AttributeError: ‘NoneType’ object has no attribute ‘makeInstance’

location: :-1

I can see where the issue arises, but I cannot trigger it myself. It looks like a missing asset. Did you set up the DAZ root paths as described in https://diffeomorphic.blogspot.com/p/setting-things-up-version-15.html?

@ThomasL Perhaps it’s time to start a discord, or something of the like?

I just checked again and it didn’t have an MDL root loaded nor the cloud Root…

So I have re-done the root directories again.
Just tried and all is working again…thank-you for pointing me in the right direction!

Hi @ThomasL , Thx once again for this amazing addon.

Im trying out the new stable version 1.5.1 and having the following problem when importing morphs:

Do you know what could be causing it? Im sure it worked with same model/morphs a while back.
If i go 1 by 1 some work, some dont. Is there a way to load the working ones even when some throw an error (so i dont have to go 1by1)?

Thx in advance!

I have some morphs for dicktator that import with no error, but end up not doing anything. Namely its the following, Scale All Segments, Scale All 1, Scale All 2.

They import, add a custom property to the rig but does nothing. They also seem to not be attached to, or controling anything. They also do not get added to the “custom morphs” area of the addon menu.

Anyone have any idea what I’m doing wrong. Also, I just assume it’s me messing doing something wrong.

The morph system is going to be completely rewritten in version 1.6, and I don’t want to investigate in detail what went wrong in the old version. Probably something changed when FACS morphs were supported. However, the plugin does not raise an error at this point anymore, but just ignores the driver. Since I don’t have any asset that triggers this error in the first place, I’m not sure what will happen downstream.

This is an update to the version 1.5.1 branch. I made a quick bugfix release 1.5.1b that contains this and a few other fixes. https://www.dropbox.com/s/d087603vz5hmau0/import_daz-v1.5.1b-20210302.zip

1 Like