DAZ Importer

Well, I’m already monitoring the bug tracker, this thread, and the Blender discussion at DAZ, and I don’t need more places to check. Besides, I am skeptical of solutions that cost money, even if it is not me that is paying. If somebody fails to pay the bills, the site will disappear eventually. That happened to our company dropbox at work (but almost nobody was using it).

1 Like

I didn’t realise discord cost money, I also didn’t realize the bug tracker was so active. I hadn’t checked it since you moved the project over to bitbucket. I don’t blame you for not wanting to keep track of a million different platforms, it’s a PIA. Thanks for the reply though.

Well, I don’t know either, but somebody made the same suggestion a while ago and offered to pay for it.

Hi Domiek!

I read the forum, but I still do not understand. Did you manage to solve the performance problem?

It looks like I have the same problem. Now I work with fps in the region of 0.5-1.5 and it looks like some kind of step-by-step strategy in general regarding the response from the blender. disabling modifiers and objects, including completely all daz objects from the scene, does not change the situation.

my pc spec is r7 1700x, gtx 1660, 32gb ram

Hey Sergey. I’m not sure what the problem is since my comment you responded to doesn’t state any issues. The only performance issues I can think of from the past was solved when Thomas made Daz meshes be stored into Collections automatically.

Be sure to disable everything in the viewport except the base mesh with modifiers disabled and work your way up from there to isolate what’s causing lag.
image

2 Likes

Hello, does anyone know how I import expressions I bought in the daz store like Jumpywhirl Mix and Match Expressions?

On blogspot coments now off? Check this page pls.
You wrote MHX runtime system has been moved to a separate add-on.
Where can get this addon, or just need instal MHX addon for blender?
Anyway, Tanks 4 Ur work.

As I wrote in the blog post, the main documentation page for the MHX RTS is http://diffeomorphic.blogspot.com/p/mhx-runtime-system.html. The repository itself is located at https://bitbucket.org/Diffeomorphic/mhx_rts. And the dev version as a zip file is at https://bitbucket.org/Diffeomorphic/mhx_rts/downloads/.

The comments were turned off because I don’t have time to monitor them, and notifications about new comments are sent to a mailbox that I don’t monitor either. Having lots of comments that I don’t see and don’t answer looks bad, so I turned them off. I’m using the site for documentation and not for communication.

2 Likes

The Setup > Morphs > Import Custom Morphs button opens a file selector where you can select the morphs you want to import. If the active object is a mesh, the morphs are imported to that, if it is an armature they are imported to the associated Genesis mesh if any. By default the file selector opens where morphs for this kind of mesh are located.

2 Likes

So I’m getting this error while trying to import a second character. It worked fine for the first… I already checked my global settings and all are confirmed correct, and all settings are set to default. Not sure if I’m doing something wrong, but if someone could help me out I would really appreciate it.


Python: Traceback (most recent call last):
File “C:\Users\cpose\AppData\Roaming\Blender Foundation\Blender\2.92\scripts\addons\import_daz\error.py”, line 247, in execute
self.run(context)
File “C:\Users\cpose\AppData\Roaming\Blender Foundation\Blender\2.92\scripts\addons\import_daz\daz.py”, line 48, in run
getMainAsset(self.filepath, context, self)
File “C:\Users\cpose\AppData\Roaming\Blender Foundation\Blender\2.92\scripts\addons\import_daz\main.py”, line 76, in getMainAsset
inst.preprocess(context)
File “C:\Users\cpose\AppData\Roaming\Blender Foundation\Blender\2.92\scripts\addons\import_daz\node.py”, line 209, in preprocess
geo.preprocess(context, self)
File “C:\Users\cpose\AppData\Roaming\Blender Foundation\Blender\2.92\scripts\addons\import_daz\geometry.py”, line 82, in preprocess
self.data.preprocess(context, inst)
File “C:\Users\cpose\AppData\Roaming\Blender Foundation\Blender\2.92\scripts\addons\import_daz\geometry.py”, line 432, in preprocess
for extra in node.extra:
AttributeError: ‘NoneType’ object has no attribute ‘extra’

location: :-1


I’m trying to animate two characters in the same scene, and I’ve been stuck on it for a few days so I’m fairly frustrated at the moment.

Thanks in advance.

I just gave it a try…
Make sure to make the FIRST import Invisible… Hide the Collection…
Re-select the original empty collection and then import your second character…
and all should be well…
Daz 8.1 and a Daz 8.0 characters…

Thank you very much for the quick reply, I will give it a try and get back to you.

Edit:
Sorry to bother you again, but I am still getting the error. Now, I can’t import the first character and it throws the same error as the second character. I did try what you suggested, so here are some pics that might help diagnose the problem:

Maybe I should cut my losses and go back to trying to animate with Daz’s terrible IK system, or just work frame-by-frame. I apologize, not trying to sound ungrateful. It just seems to be one thing after the other with this scene lately. I really do appreciate the help.

Also, here’s a pic of the files that I have from the export (.duf, .png, .dbz).

After some troubleshooting, I discovered that the error is specific to the second character. I’m not quite sure what I’m doing wrong, as I have been able to import “Jake” but not “Rebecca”. Also, nothing was done differently during the export from Daz between the two.

Edit:
It seems I can import the first character twice, but can’t import the second which tells me it must be a file error. I’ll try some more troubleshooting.

Edit Again:
:man_facepalming:
Ok, so now I feel like an idiot… Turns out there was something wrong with my model, so I all I had to do was rebuild her from scratch. Took a while, but now both models transfer to the scene without issue. Thank you very much @RSEhlers, I would have never figured that out without your help. Now I just have to figure out how to get several parts to import over that apparently have too many subD’s. If anyone has an idea, I’ll take any suggestions I can get. If not, I can probably fix it when I send it back to Daz.

Glad to got it fixed!

Are you talking about the character or other bits you are adding?
I actually don’t send anything back to Daz though I might as I have some clothing I want to get on the characters…
As far as Sub-D… I usually only add 1 or perhaps 2 levels, MAX as even with that animation grinds to a halt like .2 frames a second! ( sub-d on top of shape keys will not play well together)

Thank you, me too.

The character in particular was the issue. I saved her as a character preset, then loaded into a blank scene and made the necessary changes and additions to bring her back to what my previous renders looked like, or as close as I could.

For the most part, I’m only using Blender to animate. I’m fairly new to the software, both Daz and Blender, but have learned a lot in Daz and am unsure about having to learn another program from the ground up. I have quite a bit of experience in 3d modeling, but it’s been almost a decade, and it was 3ds Max rather than Blender.

Turns out, the issue was certain anatomical elements and geografts that were too HD for the import/export process. Thankfully, I found the “HD Meshes and Geografts” tutorial in the documentation and am on my way to getting that rectified.

I’m keeping my sub-D at zero (I think, no dialog pop-up on export), as I don’t want any more hassle than I’ve already gone through for this one scene. I’m already further behind than I want to be, but you’ve helped me out immensely. That bit about turning the first character invisible probably saved me a good several hours of searching, and I’m very grateful for the help.

Hi, me again…

So I am noticing that the only mesh that responds to posing is the SD mesh, not the HD mesh.

Better detail:

Upon importing HD character, two meshes (SD and HD) are imported into the scene. This gives the character an odd look, as parts of the meshes are overlapping(?) each other. As I am wanting the HD mesh to be left behind after merging genitals etc. (according to HD Meshes and Geografts tutorial), I copied the vertex groups from the SD mesh to the HD mesh thinking that would solve the problem. Apparently, not quite. The HD mesh still does not move, only the pose gizmos.

I’m not sure if I am doing something wrong, or if this is how it’s supposed to work. I’ve followed the above tutorial step-by-step, and deleting the SD mesh is required. But, I can’t delete it because it’s the only mesh that can be posed, and I can’t hide it because that’s pretty much the same as deleting it. So, I’m stuck between a rock and a hard place or whatever analogy you want to use.

My question: Is there something I can do to transfer posing ability from the SD to the HD mesh? Without it, I will be stuck with the SD model, which I am sure will decrease the render quality I have been achieving until now.

If anyone has a solution, I would really appreciate the help. I have searched every variation of my question in as many places as I can think of, and have come up with exactly diddly.

Let me know if screenshots would help.

Not sure why, but I’m not able to merge geografts anymore with the imported model from DAZ. I have the latest version, and I think the option has moved to the setup tab, but there aren’t any options listed when I open the tab.

I was able to do it by following the tutorial I mentioned above (HD Meshes and Geografts). It’s a bit of a process, but it worked for me. The only issue is what I said in my previous post, which pretty much defeats the purpose I need it for.

I don’t think that’s the problem I’m having. The options to merge geografts or merge rigs just don’t appear at all anymore on the latest version of the importer, so I don’t really know what’s going on.