DAZ Importer

add-ons

(danhaske) #61

Please is there any way of importing faceshift animation to Daz character as we did with makehuman


(ThomasL) #62

Sorry, no. Faceshift outputs a sequence of values for some morph targets. (List of morph targets.) It worked in MH because those morphs were implemented in MH, at least for some versions of MH and FS. I don’t know how well the FS morphs can be mapped to the DAZ morphs. If there is a good match, it should not be very difficult to implement FS support in the Daz Importer.

However, there is another problem. I no longer have access to any FS files, and AFAIU Faceshift itself is no longer available after Apple acquired the company. So implementing FS support does not seem to be very useful anymore.


(dissectionalone) #63

This importer is a great idea :slight_smile:

I have a doubt though: How do you get the character with the clothing, hair and anatomy etc into blender using the importer?

Because when you save a character in Daz it doesn’t save hair or clothing items, geografts or props along with it unless you save the scene (as far as I’m aware at least) Never tried saving as a wearable preset but don’t think it would work either.

Thanks in advance.

Cheers


(Bob Morane) #64

Hello Thomas. This addon is a great idea but it still doesn’t work very well with older (4th generation) models.

After i saw this thread i decided to try and see if i could get my old Michael 4 some new purpose but even thought he does import correctly (without any error reported on verbosity 3) the rig is non functional and i don’t have access to any morphs (the list is empty even thought i loaded all morphs on Michael in Studio).
Some hair i had from that era also don’t import very well. I have to put verbosity to 2 to get them to import at all, they appear way above Michael, slightly too large and don’t transfer correctly to the particle system.

Now i realize Michael is pretty old but the model is still quite good and i have all his (main) morphs unlike any Genesis (only the free “base” models). Is there anything i can do to load morphs and expressions manually. Manually rigging him is possible (if time consuming) but without expressions he won’t be very useful.

Is there anything i can do to help you add support to those older models (if you plan to). I’ve read you don’t have them. I have both M4 and V4 and some clothes/hair so i could test stuff if you want.


(ThomasL) #65

Sorry but I don’t understand. Of course you have to save the file before importing it into Blender. If you do that, hair, clothes and props are definitely imported into Blender. (You should also save a separate json file with the final world-space coordinate as described in the docs.)

Or did you mean that hair, clothes etc are not stored in the duf file? Yes, this is how DS works. It stores pointers to external asset files which in turn may contain pointers to other files. The core of the DAZ Importer is that it replicates this mechanism.


(ThomasL) #66

Hi Bob,

If you send me the models I will see what I can do. Probably best if you put the files on something like dropbox and send me the link as a private message.

The importer does not import any morphs directly. There are really two kinds of morphs: those that define the character and those that are used for posing. To get the first kind of morphs into Blender, you need to save a separate json file in DS with the script that comes with the importer. This stores the final world-space locations of all vertices, so it is the sum of all morphs that you used in DS. It is a bit of a hassle to set up the export script, but you only have to do it once. See http://diffeomorphic.blogspot.se/p/installing-daz-studio-plugin.html and http://diffeomorphic.blogspot.se/2017/07/json-fitting.html.

The second type of morphs has to be added to the character after it has been imported into Blender, cf http://diffeomorphic.blogspot.se/p/morphs.html. There is a shortcut for loading facial expressions for Genesis (1, 2, 3, 8) characters. Perhaps this works also for M4 and V4 (the importer looks at the mesh to determine what kind of character it is). Even if it doesn’t, you can still load the morphs but you need to know where the morph files are located.


(ThomasL) #67

The DAZ Importer (development version) can now create Cycles materials using the Principled BSDF, also known as the PBR shader. Here the same car has been imported with Cycles with PBR, Cycles without PBR, and Blender Internal. Quite a difference if I may say so myself.






More details at http://diffeomorphic.blogspot.se/2017/12/pbr-shader.html.


(Bob Morane) #68

Sorry for not answering faster. I’m not here very often.

Yes, i know the difference and the script works fine, i gave it it’s own shortcut for easy access. It’s the “Face units” and similar expression “poses” that don’t show up on the panel with my older Generation 4 figures. If i can load those manually it’s not an issue, i’ll try to load them like JCMs. Well, there’s always some sale going on at DAZ so i might end up upgrading to some newer Genesis anyway, i already grabbed a few morphs for free since i posted that.

I came here to talk about those newer figures this time. Among the freebies i grabbed was Michael 7 (for Genesis 3) and it’s “HD” morphs. When i first saw those HD things i thought they were using normal maps or something to improve the final render but it’s actually something different. It’s probable old new for you but i learned they are morphs applied to the additional geometry created by subdivision. When i read this i wondered whether or not those would work inside Blender and i decided to do some tests with my free Michael.

Unsurprisingly, when i imported a scene using your add-on, all the HD details were gone but i new Blender had a feature that could probably handle that sort of details : Multires. So i exported a subdivided Michael as obj from DAZ studio and tried to import it into Blender. 4x subdivision ate all of my RAM and crashed even thought a 4x subdivided Michael inside Blender is possible but it looks like the obj importer is really memory crazy. 3x subdivision did import without any troubles. I added a multires to the rigged Michael created by your addon, subdivided 3 times and then tried to figure some way to transfer the high frequency details from the obj to the multires mesh. Reshape button totally blew the mesh possibly due to different subdivision algorithm (Studio uses Catmark while Blender uses Catmul-Clark) but i found a workaround in an old post by michalis : using a shrinkwrap modifier.

Here’s the result on Michael 7 with it’s HD morphs applied in the Blender viewport with Matcap applied to avoid any texture interference (sorry for crappy jpg compression)




Unfortunately, some detail is still lost with only 3 levels of subdivision. I had hoped to get the 4x subdivision inside blender at least once to bake a normal map but i can’t. Maybe someone with more RAM could do it. Still a lot more detail here.

Maybe you already figured this but since there’s no mention of this option in the documentation of your add-on i thought i should let you know. The process is a little tricky and i probably wouldn’t have figured it without michalis post. I can give a complete step-by-step guide if you prefer.


(ThomasL) #69

Sorry for not answering faster. I’m not here very often.

Neither am I, hence my own late reply.

It’s the “Face units” and similar expression “poses” that don’t show up on the panel with my older Generation 4 figures.

The script recognizes a number of standard characters and knows the paths to the standard morphs made by DAZ. The tables are hardcoded at the top of the file morphing.py. If your character’s morphs are located elsewhere, the script will not find them.

Moreover, the script may interpret you older figures as a Genesis character of some kind. It uses the mesh’s fingerprint (#verts-#edges-#faces) to determine the mesh type, and if your figure is a morph of a Genesis mesh, the fingerprint will be the same. The mesh and rig types of the active object are displayed in the Utilities panel.

I came here to talk about those newer figures this time. Among the freebies i grabbed was Michael 7 (for Genesis 3) and it’s “HD” morphs. When i first saw those HD things i thought they were using normal maps or something to improve the final render but it’s actually something different. It’s probable old new for you but i learned they are morphs applied to the additional geometry created by subdivision.

No, that complete news for me. I noticed that some morphs have names that end in “HD”, but I never thought more about it.

Unsurprisingly, when i imported a scene using your add-on, all the HD details were gone

Yes, that’s the way the importer works. Normally it is much better to subdiv in Blender after deformation is done. Besides, my computer is from 2009 and not so powerful, so I’m pretty allergic to dense meshes.

Anyway, it is good to hear that you managed to solve your problem. And the shrinkwrap trick was clever.


(naughtyhorse) #70

I have been playing with this plugin for the last couple of hours and…
I am utterly astonished! Brilliant work!!1!
I was seriously impressed with the mesh and morph importing…
and then i saw the ‘Hair’ panel.
particle hair from daz mesh hair???
mind=blown.
thanks you very much.
(and the help file is great too)


(loper) #71

hey thanks for your work
but g3f is loading without rig there is no bone is pose mode


(steven850) #72

Hi, First off, this add on looks amazing!
Seems to do absolutely everything and I look forward to using it.
I do seem to have run into an error,Trying to import my character to blender.
Getting the following error on import
ERROR:
SKIN: Expected geonode but got:
<Figureinstance Genesis3male 0 P:None R: <bpy_struct, object"genesis 3 male.001… The rest is not readable as its truncated.
I checked the documents folder where the error log is supposed to be dumped, but its not creating an error log. Any ideas? on whats causing this error?


(ThomasL) #73

Um … no. I have no idea what can have gone wrong, but if you don’t do anything strange the rig is certainly there.



(ThomasL) #74
  1. Try to increase Verbosity in the General section of the Settings panel. Perhaps no error log is generated if Verbosity is too small.
  2. The importer has been developed on Windows 7 and works best there. It has been tested on Windows 10 but not so much, so perhaps some permission issue prevents the log file to be printed. I don’t have access to Mac so if you use that I really can’t help.
  3. Try to switch to the most recent version from https://bitbucket.org/Diffeomorphic/import-daz/downloads/ . This type of problem did arise before but I thought that it had been fixed.
  4. Remove objects in Daz Studio and try again until the offending object has been eliminated. A nude Genesis 3 male should definitely import without problems.
  5. Start Blender from a DOS/terminal window. Trace and error messages are printed in the terminal and can give some hint about the problem.

(DLux) #75

ThomasL, thank you for this incredible tool! I’ve been playing around with it over the last few months, and it is making me seriously consider leaving DAZ studio Behind for everything but preliminary character setup!

There is only one obstacle that remains, and that’s corrective morphs, without which most poses look unnatural. I’ve been able to import the “base correctives” folders for Genesis 3 figures, but the fact that these have to be dialed in manually is still to cumbersome for anything except one-off images. Also, it seems like DAZ is touting improvements in corrective morphology as the key feature of the Genesis 8 series, so the fact that it doesn’t make the leap to Blender is disappointing.

I saw there was some discussion of this on the Bitbucket page, and your point that it would be a lot of work to set up is well taken. Perhaps you could meet us halfway and code an option to easily assign a bone rotation control to a shape key? We’d still have to set it up ourselves, but we’d only have to do it once.


(steven850) #76

increasing verbosity still did not create an error log for some reason.
I am on windows 7, and have figured out the problem.

In your tutorial you specifically said to save in daz as a Character preset. So I went to save as and the character preset. This is what was causing the error. Apparently you have to save as a scene and not a character preset. You should change the wording in the guide to say save as scene and not as character.

You said in the guide that the default scaling of .1 gives real world sizes in blender but it does not. My character was 13.2m tall :stuck_out_tongue: to get real world sizes I had to change the scaling to .01 to get a size of 1.32m. So this would be pretty confusing for most people, would be great to change it either in the guide or change the default.

Then I spent several hours trying to figure out problems I was having with hair. It was converting to particle system just fine, but the children never displayed correctly. They where just floating in space around the head and at all sorts of directions and angles. Took me ages to notice the radius setting under children was causing all the problems. Your script seems to automatically adjust the cycles particle scale based on the import scale setting, so the hair is always the same size relative to the character. It doesn’t take that into account when setting the radius on the children particles. So the setting here needed to be .02 instead of .2 hence all the hair problems.


(ThomasL) #77

You mean the starting page of the documentation, item 7 in the instructions? Sorry, I didn’t realize that you might interpret the phrase “DAZ character” as character preset. Changed to “Daz scene” instead.

I don’t use any units in Blender, so a character that is 132 cm in DS would come in 13.2 BU tall in Blender with the default settings. That’s what I meant by saying that the default scale is dm. I will have to check what happens when you actually set phyical units in Blender.

Particle hair is brittle in Blender, and it is very easy to break it. I don’t think that it is the plugin that causes the problems, but the particle system itself.


(ThomasL) #78

I’m taking a stab at this now. The code is more or less working in the development version, even if there are some bugs left to crush. Beware that adding corrective morphs makes the character very heavy. A nude genesis 8 female weights in at 5 Mbyte without and at 24 Mbyte with morphs, so the file size increases fivefold.


(slawdos) #79

Tanx 4 great job.
How can I change the materials now depending on the renderer in v1.3? Only when importing a character?


(ThomasL) #80

You mean conversion between BI and Cycles? The button is still there, but it is hidden. To unlock it, enable HIdden Features in the Settings panel.

However, it does not work so well and I don’t really want to support it, which is why it was hidden. In particular, the principled shader is completely ignored.

I think I have seen some plugin that converts between BI and Cycles in general. But I don’t know where.