DAZ Importer

add-ons

(Creiz) #121

Hello!

First of all, thank you for your work. This plugin is amazing.

When I import some shape morphs(like titties or muscles), though, they do work on the model itself, but they don’t work on the clothes.

How can I fix this?

EDIT: Please disregard. The feature is working as intended, I tried it with a Genesis mesh and it worked fine. The issue is with my own mesh, which is an unofficial figure and the fact that the garment in question is a custom one. It does morph and move in DAZ, because it’s conformed to the mesh, but it has no morphs of its own.

Now I’ll have to figure out how to conform my garment to my mesh in Blender directly, see if that fixes my problems.


(Handel) #122

Thanks a lot!
Just came here to check when 1.3 will be released:-)


(Handel) #123

A lot of artists make the morphs for their Daz items in Blender so this shouldn’t be a problem and I think I such tutorials on utube.


(Philmister978) #124

I’ve had this problem before, but I’ve since switched over to a new machine, and I think it bears repeating.

So, I’m trying to import .duf models into Blender, and I keep getting “invalid path” errors whenever I try to do so. I switched the file sources from “My Library” to “My DAZ Library” within my documents folder, and I keep getting the same errors. And this is after I tried one path and two paths (the attempt with one path is included). And what bugs me as much is that it tells me to read the documentation, but I don’t know where the heck that is. And I can’t read the error messages because they don’t save out to their assigned destination. So what the heck am I doing wrong here this time?


(marf) #125

Its not complaining about your library paths.

its complaining about the lack of a .json file.
its expects to find a json file named “asobi.json” in “F:\3D”
Did you export the json file from daz?


(ThomasL) #126

You mean 1.4; 1.3 is the current stable release. Probably towards the end of the year, depending on how long it takes to port to Blender 2.8. I have heard that the api for Blender 2.8 will be available by mid September, so a few months after that.


(Philmister978) #127

And that’s just the problem, how do I save into .json? I can’t seem to find the option when I try to save out of DAZ3D.


(loper) #128

follow instruction


Workflow: Daz3d 4.10 > Blender 2.79 > Mixamo > Blender 2.79 > Blender 2.8
(Handel) #129

I created a scene in Blender but because of the genitals I need I made characters in DS. So I (with a help) imported the main objects of the scene to Daz and right now I am fine tuning the poses there. Then I have to import the already posed character to Blender with the script. But because of the fine tuning of the poses (looking at eyes etc) I plan to export the models with the props from DS to Blender as parented objects as a single OBJ and then replace the the imported as OBJ models with the posed models imported through the script. Is the feasible? And is there another, simpler way to do it?


(Safetyman) #130

Pose your characters in DS and save the pose(s) to a file. You can do expressions as well – and it doesn’t matter which DS figure you use as long as it’s compatible with the character you’re using importing into Blender (i.e., a Genesis 3-compatible pose file must be used with a Genesis 3 exported character) Once you get the characters into Blender by way of the Diffeomorphic tool – click on the imported rig, click the Import Pose in the Diff tool panel, and navigate to the pose(s) you saved.


(Handel) #131

Thanks. What you mean as “imported rig”? Must I select all the rigging in the imported character or there is button to select it in the tool panel (I worked a little with 1.2 several months ago)? Also at which coordinates will the imported figure appear in Blender? The coordinates at which the posed character is saved as Posing Preset or at the coordinates where the character is imported by the script?


(Safetyman) #132

The imported rig is the one that loads with the character when you import it into Blender via Diffeomorphic. You select the rig in pose mode to import/apply poses… tap the “a” key to select all the bones. My suggestion is to read the included manual.
Not sure what you mean by coordinate… everything should be at 0.0 initially.


(Handel) #133

I have a problem importing the JSON file. Several months ago I tried 1.2 version and the import was working, so have some experience with the script.

  1. My program Daz Studio 4.10 is installed on D: so I have 4 paths all of them included in the script settings (and 1.2 worked with them; there is 5th daz path too but it contains only the auto-installer so I ignored it - C:\Users\Public\Documents\DAZ 3D\InstallManager)
  2. I had 1.2 import script installed so I think I deleted it (not physically but by deleting the custom action for it at Window - Workspace -Customize and making a new one in D:/My DAZ3D content/Blender Export/export_basic_data.dsa
  3. In my path C:\Users\Genko\Documents\DAZ 3D\Studio\My Library I had subfolder Scenes where were my .DUF files (planning to re-save them from there but later). In the folder Scenes I have a .DUF file called 2nd_guy.duf. I started the export script and copied the name 2nd_guy.duf, clicked Save and 2nd_guy.JSON was created successfully (BTW - it was only 115 bytes while the DUF file was more then 700k, and the json file was created for less then a second)
  4. Now I tried to import the JSON file both ways - through the File-Import command and through the script button Import Daz file. I both cases the program doesn’t see the json file so I clicked on both 2nd_guy.duf and 2nd_guy.duf.png. And as result Blender just stops responding and nothing more.
  5. I have self-made cloths on the 2nd_guy.duf and as I made them several months ago in Marvelous Designer I forgot where the textures are (but when exporting from MD to Daz they were copied to one of the paths) - but I guess even if the textures are missing this should not create a problem with the importing.
  6. Here are the paths in the Blender and the error log but the error log was not created at all - at least not in the specified path. Oh, and I use Win 7.
    paths
    Please advise.

(Safetyman) #134

I’m not the author of the script, so I don’t really know what is going on with your issues. Are you importing a Daz character or just some clothing? I don’t know if the script handles scenes without a character in them – I’ve tried to import other things and it doesn’t work – I believe it has to do with the rigs. The .json file isn’t what you need to import/open – it’s the scene file (.duf) – I think the script just uses the .json file to find all the stuff needed to load the scene. Hope this helps a little.


(Handel) #135

Yup, I need to import characters with clothes in Blender, just the clothes I used now are self-made and both the mesh and the textures are not in the default places but still in the paths.
How big is your generated json file in comparison to the duf?

Edit: I did a test with naked basic G3M (unmorphed) and it was imported successfully. The json file itself was much bigger then the duf file, but in the previous attempts with morphed and clothed G3M model the json file was only 115 bytes; will make more tests now.

Edit 2: I imported it this time; have no idea what exactly was the reason for the fail before but today when started DS the custom action was missing from the file drop down menu. Guess something went wrong with the export script yesterday.

BTW - the hair as well as the skin are white.

Edit 3: Just thinking about it - I deleted the custom action with the old script but made a new custom action with the new script w/o restarting DS. May because of this the 1.2 script actually was working trying to make the json files?


(Safetyman) #136

Try the 1.3 version… not sure if it will improve anything but it’s usually a good idea to work with the current version of things since it could include bug fixes.

As for the textures upon import: They are generally good by default, but I find I have to adjust some of the textures myself – especially things that have transparency due to the differences in the two programs. I tend to just redo all the textures anyway just because I know what kind of nodes I want to use and I know how they are working with my particular scene.


(Handel) #137

I am doing this with 1.3 and it seems to work now; what I was wondering if the leftovers from 1.2 was messing with the exporting correct JSON file. It doesn’t matter really. It works now (1.3) as intended.


(Handel) #138

Damn! Damn! Damn! It happened again! I decided to test the guy with the self-made clothes vs the same guy with some random Daz made clothes and it happened again - 2 fake JSON files 119 bytes each!
Hah! This time they worked both! I had in the same folder an older JSON from tonight (20+ MB size) with the same guy but different cloths and I think different ttextures and it seems Blender took the info from the old JSON.
Here are both small JSON files just for info:
1test.json (119 Bytes)
1test.json (119 Bytes)


(lexabesed) #139

Very cool addon, waiting for version 2.8


(slawdos) #140

Prepare model in 2.79, save as .blend and open in 2.80. :sunglasses: