DECALmachine

Hi, I have issue with installing PIL … it installs, it’s in the proper folder, tha addon says it’s been installed, and when I reload, it asks to be installed again…

apparently I got it working on 2.83… some error messages - some folder were read only

Report it properly please: https://machin3.io/DECALmachine/docs/faq/#get-support

I got it working on 2.91.2 versions, the newer versions still have a problem with detecting PIL…

In any case - how is the “update it!” feature supposed to work - it updates and puts everything into IN_PLACE folder - and then it gives out and error message of unable to access file “WinError 5 Access is deined” I am guessing it seems like it doesn’t have writing rights to copy back to original folder …
… BTW my setup is totally customized, my addons are on drive D under google drive/blender/scripts (so I can backup automatically all addons) … maybe it’s why it gives and error - IDK

I manually add each folder to move back from in place to the original - how is the update supposed to work, automatically replace the original folder - or manual like I do it? I don’t even know if that’s the proper pipeline…

Dude report it properly. This is a waste of time.

1 Like

it’s complicated to report, I’m gonna convert them manually, can you at least tell me if it should auto update?

Sure that’s the reason lol. It’s so complicated to press a button, that I specifically made for this, and which ensures I get all the info I need to help you.

Please refrain from asking for my help in future, if you aren’t willing to follow procedure. This is a waste of my time.

Look, I know you’re busy and everything, but still not the best way to tell a customer that I’m wasting your time.
In fact - you are wasting my time, as I am using my valuable time to send debugging info back to you - there wouldn’t be any time wasted if you sorted out the bugs in the first place …

I’m gonna send the info now… and no it’s not 1 click, I have to find some receipt, download a few files and send email… you could try a way so it’s actually a 1 click, and I wouldn’t bother writing here…

Change your mix node to ADD…

No you haven’t. You haven’t send me anything useful yet. I could have solved you issues already had you just following the fucking instructions.

Beyond that, you aren’t only wasting my time by posting this here in public, you are wasting everyone’s else time reading this too.

Also, most people who hesitate to report an issue properly aren’t actually customers. So there is that too.

2 Likes


When using the decalMachin3 if the mesh doesn’t already have a specific material applied (in this instance trim_edges_01) instead of using the material already in the scene, it will make a new one called, again in this instance, trim_edges_01.001

They build up over time with continued use, obviously if i go and pre apply the material i want to the mesh before hand i can prevent this but i feel like that defeats half the purpose of decal machine, the speed.

Is this a known issue? user error? some hidden setting i don’t know about?

version 2.4.1 for the record.

Only happens for meshes with None materials. Block in your materials using basic pbr materials, before adding trims.

For me it still does it even with materials assigned.
Repro;
Add cube
Assign Material (basic PBR)
Open DecalMachine pie, pick a panel trim
duplicate material is created.

Only way i can get it to not make a duplicate material is if the trim sheet material is in slot1 already.

https://machin3.io/DECALmachine/docs/faq/#get-support

The fix to converting old version decals properly is to put the decalmachine in the original folder where it installs by default, and use it’s default folders to convert

I do use a complex setup, and one of the issues was the writing rights didn’t work properly - well I did figure it out on my own in the end but thanks for the input @MACHIN3

That’s what I was telling you all along AFAIR.

yes, but not on my end as far as I could have figured it out, I enabled all rights on every possible way I could imagine, I’ve changed folder to some windows default, in case it’s some system issue, and the only place where the writing rights worked was the default addon folder - I think it can require further investigation, but like I said the quick fix is to use the defaults - which majority already do…
A mention of this would have saved me a few days troubleshooting, the default folder was the last thing I tested (unfortunately)…

Anyway in any case - if someone gets error messanges when converting - use defaults if you didn’t already…

It absolute is an issue on your site. I don’t change permissions to your file system in DECALmachine.

v2.5.0 is out! | https://decal.machin3.io - Gumroad, Blendermarket, Documentation

See what’s new .

Changelog

  • support Blender 3.0
  • in Blender 3.0, introduce Decal and Trim Sheet Asset Update
    • add Update21DecalLibrary tool
    • add Update21BlenderFile tool
    • update BatchUpdate tool
  • update Validate tool
  • further harden asset registration
    • add additional system console output, if assets fail to register
  • make Decal and Trim Sheet material deduplication more efficient, improving scene load/update performance
  • properly deduplicate Trim Sheet materials, when initiating them on meshes without existing materials
  • improve MyDecals library collision handling when changing assetspath
  • improve RemoveOrphans tool
  • improve GetSupport tool
  • addon preferences
    • add option for legacy line smoothing
    • add warnings in addon prefs, if assets fail to register
  • remove legacy code for Blender pre-2.93
  • drop bgl module use for view3d drawing (except for legacy line smoothing)
6 Likes