Decreasing render time and noise in Cycles

Hi! I’ve rendered this in Cycles it took 15 minutes with GTX560 Ti. It’s only 500 Samples!!! Haha
This is not about the models it’s about the image quality. I used progrresive refine so it took longer than normal, I’ve filtered glossy, setted the limit for clamp at 1.5. What else could I do to increase render quality and speed? I mean it’s OK already but still any ideas?
That was 182462 verts.
Resolution is 1920x1080

Using clamp or/and filter glossy will only degrade accuracy (quality) by definition. You must well know what you do when touching them. In fact, that scene will render in openGL in fraction of second, as you actually turn GI render to dumb 1960-year gourand shading with specular reflection.

Clamp does indeed decrease noise and if very small value is inserted in a glossy scene it won’t be acurate at all but in this case everything is OK with it. I want to keep realism and the speed, but not make it render black screen at no time.

I heard that for GPU rendering you will want to decrease the number of tiles, while for CPU rendering you want to have as many tiles as possible. Also, you may want to limit the number of bounces if your scene does not depend heavily on bounce lighting.

Tiles size 16 is best for CPU and most often 256 is best for GPU. Decreasing bounces gives huge effect but not with glossy enviroment (then it won’t be accurate). Not much new stuff but thanks for the reply!

I’ll render the same scene just on speed now.

Well it took only 2 minutes and 35 seconds. I turned off progressisve refine and decreases bounces. There’s a small difference between the images.

I was thinking, why are there 182462 verts in this scene? I would think the vert count could be much lower for the kind of shapes you have here. You might want to try to simplify your topology and that should reduce render times. Can you post a wire so we can see what you have going on there?

Yeah, so I’ve decreased verts number to 19985 (added decimate modifier) and bam it took 2:45 seconds to render and quality was lower. I think it could be because I haven’t aplied the modifier and it has to process it a little bit more.
Earlier wireframe image:

New rendered image:

Thanks for posting the wire. I think you could make the berries a lot lower-poly count. Then add the subsurf modifier and you can jack that up to 2 or three subdivisions. I think the edges are not looking as smooth as they could because there is so much geometry going on. I’ve never done experiments to see if subsurf adds to the render time the same as actual geometry, so I’m not sure of the difference. How does it look if you lower the samples to 200?