Defocus node doesn't work with transparent texture

Well, I wanted to add some dof to my scene and ran into some trouble.
The problem is, that for some reason the blur doesn’t work with textures with alpha.
It’s hard to explain, so take a look by yourself:
(it’s a little difficult to see, just take a look at the horizon and you’ll see what I mean).
All the textures have premultiply enabled.
The node setup is very basic:
So I hope you can help me :confused:

What I’ve tried so far:

  • Using Full Sample (didn’t work)

This is one of the oldest issues in Blenderland, you can probably find some fixes by doing a search.

I did do a search, all I found was one bad work-around - but anyway.
I now use Cycles instead of BI - seems to work just fine now even though setting the materials up in Cycles kind of sucks (since I have to use seperate images to get the transparency, meh).
See the result here:
But thanks for the answer anyway - I guess.