defocus node

Hi, Im having trouble with making this node work properly. The thing is that the whole image gets blurred in the end. How to control this with Cameras Focus Point? The Limits button is on, DOFDist is set to be inside on of the objects and I get only the completly blurred image.

Here is my blend file:
http://www.blender.pl/smf/index.php?action=dlattach;topic=795.0;attach=721

just turn off No zbuffer :wink: … you’re telling the node to ignore the zbuffer

Ive tried it before with no result - there was no blur at all. But there was the second thing - I had to play a little bit with the FStop value. So, after turning off the No ZBuffer and setting FStop to low value it does work. Im now after some test with animating DOF with defocus and it looks preety good. Thanks for help