Delay/lag in response to armature deformations by mesh

Please help

I’m using Blender 2.83

Kindly see the video of my character, there we can see a lag, which is really a horrible mess while animating. I may have made some mistake while making the rig from single bone. But I have checked again and again but could not identify any parenting issue or the like.

I had seen in earlier versions of Blender in relations tab, “update” option for the mesh, to update the motion of the rig as and when deformation happens.

Kindly guide me, what could be wrong with my rig, or how such delay/lag in mesh response be treated.

Open a console window (under “window” on main menu.) Look for dependency cycle warnings. It looks to me like you probably have a loop somewhere with your constraints.


there are six dependency cycles, I don’t know what to do next!
I’ll try to google, but it would be great help if a guidance is also given in this forum.
A tutorial link if any will be a great help.
OR kindly guide me, whether I delete the rig and create again from scrap.

I found one in Google.

But its hard to understand

The messages about the dependency cycles should give you a heads up of where to focus your attention-- which bones are involved in the loop. But ultimately, you need to figure out the loop yourself. Google isn’t going to help you in this case, tutorials aren’t going to help you.

Here’s an example: you have two bones, Parent and Child. Child is parented to Parent (duh). Parent has a copy rotation constraint targeting Child. Will that work? No, you have a loop: parent depends on child which depends on parent which depends on child…

Another very common example is when IK targets or poles are parented to bones involved the IK chain. That can’t work either.

But there are any number of ways to get this wrong. Nobody could tell you without looking at the file-- and honestly, it’d be better if you sussed it out yourself anyways, there’s no secret knowledge involved here.

Thanks bandages,

I solved it, there was some wrong parenting and constraints in my rig, which I found and corrected, and solved the issue.

Thanks a lot!

1 Like