Denoise artifacts related to indirect light

Hey :slight_smile:

I’m making interior scene and noticed, that with higher sampling values (4096) surfaces that should be smooth looks like one in the image.

I belive the issue is a mix of indirect light and denoise. I realized that this pattern comes from light that bounces off the floor. Blender tries to reflect floor on cabinets surface (good thing) but it went wrong. So in fact the denoiser is not the one to blame, it only increase this effect.

On test renders (about 100 samples) it was good - i belive sample count was so low, that blender wasn’t able to produce enough of this reflection, so denoiser was able to get rid of this.

I’am asking for a tip. I can’t think about any workaround :frowning:

I alredy tried:

  • increasing sample count - it goes forever like this camo pattern, not even close to smooth.
  • adding some light (i though maybe there is just not enough light) - still bad
  • changing roughness of materials - helps only with extreme values - close to 0 and 1, in between it always produce camo.
  • clamping indirect - to get rid of this i have to clamp indirect too much - it kills lighting in scene.
  • different denoisers, Super Image Denoiser gives best results - still bad
  • changing max light bounces, filter glossy,

My questions are:

  • what can i do to get proper floor on cabinets reflection ?
  • or, can i at least force Blender not to reflect floor on cabinets ?

Have you tried change “Specular”?
Check if eventually a bump map is wrong/missing.

Does it happen if you replace the floor with a wooden colored diffuse shader? Does it happen if you reduce the scene down to bare minimums; cabinet door, floor, room with window hole, nishita sky? If it does, purge everything, pack the textures still in use, and share the file. This is very hard to guess.

I checked your question - it still happens. I will share scene after deleting unnecessary items.

House_file

Here is link to the scene (hope it works).

But it may be something simple or some setting i changed and forget, because… I tried to recreate the same part of scene as in this file by copying objects, lights, settings and others to new blender file, and in new file everything looks OK - cabinets are dark and smooth.

A lot of the noise in the scene is from the ovens behind the camera: their glass material doesn’t have the shadow trick and the lamps inside are really bright. This means that most rays that hit the ovens fail to find the lights and the few that do create really bright pixels.

You should delete this entire thing. Never blur your HDRIs within the world shader. It’ll add a lot of noise to your scene and slow down rendering time by a lot. I believe this is why you’re seeing the artifacts on the cabinet doors.

Other than what has already been mentioned, have you tried assigning various lights to different light groups then checking in post nodes what is causing this? I used nishita sky with sun shining on the floor and hiding some stuff it looked ok to me, but for test renders only (40 samples, 60% full image). I did notice the cabinet material uses a texture which ended up being fixed to around 0.4, was this intentional or bug hunting?

Using the HDR but without the noise stuff (use for camera rays only if at all), I did notice a lot of color noise in the window frame area.

Something else I should add, the artifacts you are seeing are caused by the noise treshold setting. In a scene with difficult reflections, the noise treshold might have trouble picking up the entire reflection, so it will stop the rendering too soon in some spots and patches of the reflections are going to be missing.

You will want to either use a large number for the min. samples (I would try 256 to start with and tweak from there) or alternatively, deactivate the noise treshold entirely.

1 Like

Thank you for your responses. I’ve learned some new things :smiley:

For this scene @etn249 solution worked - i deleted lights that from inside of ovens and render is clean.

Lesson for me - pay attention instead of blindly adding objects from libraries. I never noticed these lights ;/

Thanks! :slight_smile:

1 Like

Woah! This is such an important thing that I’ve never known about adaptive sampling! Hey @Michal_Trybulski, I think you should mark this as the ‘solution’ instead, because it entirely solves the problem! I rendered your scene (with the oven lights behind the camera still there) with Noise Threshold turned off, as suggested by @etn249, and even at 256 samples, there’s no artefacts at all! :open_mouth: