Denoise entire PNG sequence and output to new PNG sequence


Like you see in the image - I’m trying to denoise a PNG sequence and output it to new PNG files.
I can’t figure out how to do it.
I have also tried to render an animation sequence from the video sequencer and enabled denoise in render settings, which does not seem to work.

Any tips or ideas?

As far as I can tell, you’re not doing it wrong. I did a quick test using your node setup and it works. Are you saying you get no denoised output or no output at all…? Do any of the other effects show up for you (it’s hard to tell from your screenshot)?

So, I tried this now:

Skärmbild 2021-02-20 201335

Saved through the viewer node:

Rendered with “compositor” enabled in the settings:

You can clearly see that something is not working.

I was unclear on your intent. The VSE doesn’t take into account Compositing nodes. But your first node setup is perfectly valid…

If you need to add effects to a montage created in the VSE that are not available via VSE Effect Strips, you’re going to have to…

  1. render the edited sequence out
  2. use your node setup in the Compositor – either in a new file or merely a new Scene in the same file – using the Image input node
  3. re-render

Next time you render you enable “Denoising data” in View Layer tab, and in Output tab in File Format you choose “OpenEXR MultiLayer”. You will get large output files, but you will have available “Denoising Albedo” and “Denoising Normal” pass.

To render the sequence from the compositor it is necessary that there is no “Render Layers” node, not even leaving it isolated without connections. Then you from “Render” > “Render Animation” should get compositor animation result.