Denoise not working on full render?

When I render an image in Cycles with denoiser on, it only denoises if I render a bordered portion of the image.

Has anyone had this problem before? Solutions?

I will (attmept to) attach an image from the same scene with the only difference being one was rendered with border, and the other was cropped after rendering whole scene.


EDIT: I am currently testing t osee if tile size has anythingt odo with it - I was rendering before at 1024 goal with auto tile size addon.](

So after a few tests it seems tile size makes a difference - after Having rendered the raster of a tile I briefly got a CUDA out of memory error but the renderer itself kept running.

Does anyone have any ideas on how to fix this aside from lowering tile sizes?

EDIT: I lowered the tile sizes, there is no out of memory error and at the 3rd tile the window still says it denoised 0 tiles. I clearly remember that the denoiser sometimes runs right after the tile has been rendered - is there a setting I can change to make it work that way?

Anything that you can think of can help, I’m on a project here.

The denoiser runs on a tile after it AND all adjacent tiles have finished rendering. A finished tile must be held in memory until all adjacent tiles have finished, so larger tiles mean more of the image is getting stored in memory waiting for denoise. You can minimize this somewhat by changing the tile order to left-to-right/right-to-left (for landscape orientation images) or top-to-bottom/bottom-to-top (portrait orientation images). This will reduce how many tiles are waiting for denoise. Other than that, you just need to lower the tile size.