Denoising light with volume

Hello, Blender community!

I’m facing difficulties with denoising an image, which have light and volume in it. I’ve added the denoising data in the Compositing (i’ve event tried the denoising add-on), the render samples are high, denoising data is enabled, tried with denoising the normal, albedo depth, nothing helps, always rendering it like this. Can’t find the proper settings on the web either:

P.S.: This seems to be related strictly to volumes, when I remove the volume, it renders it well without noise, but I need volume too.

Have you tried lowering the noise threshold to something like .01 or 0?

1 Like

Not only are volumes already noisy on their own, but mesh lights are also noisier than light objects. This isn’t an easy scene to render, but I have some things you can try.

  • Disable noise treshold. In a scene like this where there is noise everywhere, it will only be a pain to work with (it will miss sections and create patterns that don’t denoise well) and it won’t really help performance much. If you really want to keep it, you will need a high amount of min samples.

  • Try changing the volume sampling mode. Go to the material settings of the volume and you will find this setting, which has 3 options. Depending on the scene and how you are using the volume, it’s not always the same one that performs best.

  • I am curious about how long you are letting it render. For this kind of scene, a few minutes per frame is to be expected even on a pretty good computer, there isn’t really any way around it, unless you want to try fake the volumes with planes and transparent textures or attempt to make it look good in Eevee.

1 Like

Thank you for your advises!

I’ve disabled the Noise Threshold and got much better results:

image

The render time this time was quite a wait 1h:40m, compared to 3 min before that.

There is still some noise, but I can live with that. I will add some envoirment effects on Photoshop, wich will mask it, but overall I’m happy.

Thank you very much for your help!

2 Likes

That is a long time! Good thing that this is not an animation then!

If this was an animation, it would probably work better to just fill the shape with point lights and render in Eevee.

1 Like

I’ve also achieved same results with just setting the threshold to 0.01 as @Reg_Nullify suggested, and also lowered the sample count. This lowered the render time to 20 min. The results was same as when the Noise Threshold was disabled.

So thank you again for this tip! Much learning is yet to happen.

2 Likes

It can work well with the treshold active, but you have to be wary of strange patterns appearing. This is a risk in scenes with complex lighting effects (volumes, mesh lights, enclosed rooms, complex reflections). If the min samples are too low, sections of an image can stop sampling too soon and some complex light effects can have parts of them missing.

So in a complex scene, you can use the noise treshold, but you have to be wary of the min samples setting as it can be set too low.