Depth of Box Select in new Blender Versions

It used to be that when I used box select, all the vertices within the box would be selected. Nowadays, since the last few Blender versions, I have to change my view so that the vertices in the forground don’t occlude those in the background.

This is bugging me. I like the old way better.

Is there a setting somewhere, to make Box Select infinite in its depth, again?

At the bottom of the 3D window, next to the buttons which choose your selection mode (vertex, edge, face) there is a button with a cube on it that turns clipping on and off for solid mode. Is that what you mean?

Yes, thankyou!

When I’m cooking, some of us call it kitchen blind…you can’t see what’s under your nose.

I’ll look harder next time, though I never find it till I ask…