Depth Of Field (Blender Render)

Hello, I really need help about this.
I use Blender Render, i don’t know if that has any effect in it but, i just can’t seem to use Depth Of Field!
However, it works on material mode, but doesnt seem to be working on renders. Here is an example.



Help would be appreciated! No seriously. It’s been months and i still haven’t figured it out.

1 Like

With Blender Internal, I don’t think you can get depth of field except by adding a Defocus node to your compositing node tree.

Awh… Life really is hard for the people using Blender Internal. But thanks for your help!

I disagree! I use BI almost exclusively. (Sometimes I combine it with Cycles, and I’ve been fooling around with Eeevee.)

“Depth of field” is most-easily achieved by viewing it as a selective blur effect. Some range of distances from the camera (Z-axis distance or “Z-distance”) are to be in sharp focus; those outside this range are increasingly blurred, according to how-far “out” they are.

This naturally involves compositing, whether you are working with multiple source-files or just one. A curve node is a natural way to express the function of “Z-distance” to “amount of blur that should be applied.” The curve is flat-zero (“no blur”) within the sharp-focus range and curves or slopes upward before and after it.

Other visual effects associated with distance can be manipulated in the same fashion. For example, objects farther away from the camera (especially in an outdoor setting) might have reduced “hue and saturation.”

The key is – “Ingrid, fake it.” Since a CG camera really isn’t a camera at all, what does "look like?" Never-mind physical reality … how to convincingly mimic it?

I just figured it out! Thank you so much! ^^