Desert Town Pack

Hello! The release of the blender version of our desert pack. Hooray))) You can use it as you like, but we spent a lot of time on the implementation of things that would be useful, for example, for 3d concepting.



all videos about this pac: https://www.youtube.com/playlist?list=PLq3nIuxEiFw-xF31Ji4Hn_84gKfC1jGq1


9 Likes

Сurrently working with eevee, it’s cool. I’m in love.))
Material is similar to what I did in Unreal Engine. The only difference - Eevee currently do not have tesselation or parallax with fake shadows. Hope it will be added soon)
This is Test Blend Material:

4 Likes

nice work !!!

1 Like

Some more eevee render))
S11 S12 S13 S14 S15 S16

4 Likes

more eevee render)) for our pack
S18 S20 S21 S22 S23 S24 S25

2 Likes

Setting up objects is almost complete . Now I need to render ALL them :grimacing:

2 Likes

more renders!

Recently I found a problem. I am using RGBA texture for my custom material.
Red - AO
Green - Roughness
Blue - Height
Alpha - Metalness
Eevee works fine, but in Cycles Alpha channel influence all other channels and I have a messy result.
Is there any secret feature that I miss?

I think you need to setup something like this (note that there is Alpha output at image texture node):

Thanks for the advice! But I used such settings of the material and this does not help, since the texture that uses the alpha has a damaged picture from the color slot. As shown in the screenshots above.

Are you sure RGBA texture is properly baked? I could look if you can send the texture. (You can PM me if you don’t want to share publicly)
By the way you can use Node Wrangler addon emission viewer feature in order to preview maps/channels quickly instead of setting up that mix shader. (Addon comes within Blender)

recorded a video, for a more detailed demonstration, you do not need my scene, you can repeat for the video.

There is something wrong with that Blender.tga , because at this point (screenshot below) you should be seeing a completely red cube (according to your photoshop view):

image


Try this instead (exported a png from GIMP):

Also I noticed exporting .tga and .png from Photoshop doesn’t include alpha channels properly for some reason (.tif works).

It does not matter in which program to save the .tga (I tried), the bug remains. And the fact that eevee works well means that it is 100% of the bug. Or am i wrong?

Edit: This statement is faulty, please see my next response.

Things work properly for me. It’s high likely you’re doing something wrong.
As I stated above there is something wrong with Blender.tga file you showed in video (Please have a read again and respond to that). Also did you try the png I shared? I suspect that the texture maps you use is problematic and not the Blender itself. This is why I need a texture to test it out.

I tried different formats. Everywhere the same problem. And this problem is not only for me. My friends have the same problem.

Sorry I think I’ve made some mistakes with my tests earlier (was looking at Lookdev renders I guess) and my previous statement is faulty.

So I researched a bit and found out there is a bug report already about this issue: T53672 .

There is a workaround suggestion by user @omgold :

  • create two image texture nodes, referencing both the same image (note: this is not the same as duplicating the texture node).
  • check ‘Use Alpha’ for the first, uncheck it for the second
  • use the first node to connect RGB, the second to connect alpha.

Same issue also mentioned in this topic:

Very cool! :sunny:

1 Like

Thanks for the help. Chose the method you described

1 Like

Material Renders

3 Likes