Destructive Extrude [BETA]


(English is not my native language) #121

Hi.
Getting this error when I try to enable TestExtrude.py from user preferences (I have renamed it as “DestructiveExtrude.py”):

Traceback (most recent call last):
  File "/media/blender-2.79-linux-glibc219-x86_64/2.79/scripts/modules/addon_utils.py", line 331, in enable
    mod = __import__(module_name)
  File "/home/yafu/.config/blender/2.79/scripts/addons/DestructiveExtrude.py", line 773, in <module>
    class DestructiveExtrude(bpy.types.Operator):
  File "/home/yafu/.config/blender/2.79/scripts/addons/DestructiveExtrude.py", line 790, in DestructiveExtrude
    matrix = bpy.context.active_object.matrix_world.copy()
AttributeError: '_RestrictContext' object has no attribute 'active_object'

(Darcvizer) #122

OK, thanks

I just commented out this line, it’s not where not yet used.


(Darcvizer) #123

I rebooted the file.
I need to know whether it leads to crash on other systems.
this - https://1drv.ms/u/s!Ahee30jehakNgiK6-PWrQ8yJ2CPp
or gitgub - https://github.com/Darcvizer/Destructive-Extrude


(JoseConseco) #124

I got instant crash as soon as pressing x,y,z on simple box (win 10 64bit os, blender 2.79). Actually It worked once.


(Darcvizer) #125

Thank you.


(English is not my native language) #126

In which version of Blender are you developing the add-on?
I get crash in 2.79, and the plugin kidnap the mouse pointer into viewport in 2.78c :slight_smile:
Linux 64 bits.


(Darcvizer) #127

Thank you.
I do not know what causes the falls EXCEPTION ACCESS VIOLATION
I will use Google …


(Darcvizer) #128

I decided to rewrite the code again.
Try the new file. On my system of falls it was not noticed.
I did not have time to do it:
1 / bevel updata
2 / snaping
3 / keyword input
I’ll try to finish the next weekend.
https://1drv.ms/u/s!Ahee30jehakNgiNBiTwfBvtUXjNC


(thierryvm) #129

Hello Darkvizer, I just discovered your addon that I find excellent at least from what I see in your video but for my part alas, it is impossible for me to use it and it does not matter the version used here (0.9 ), I made you a .gif to show you my worries.


(thierryvm) #130

Hello Darcvizer, for me i have this problem with all versions. I have try 0.89 and 0.9 too. I use blender 2.79


(Darcvizer) #131

I’ll just leave it here.


(EEEnt_OFFICIAL) #132

Wow that looks quite intuitive!


(Darcvizer) #133

I finished the work on offset. It is needed to ensure that geometry does not disappear.


Here is the difference between previous versions.

Attachments




(atekdigital) #134

Is that making offset of mesh with faces or just offset. Reason i have a offset addon which make offset only and edge not the faces. http://pasteall.org/pic/index.php?id=119661.


(Darcvizer) #135

Please try the new version 0.9. At first glance, it’s ready, but you need to make sure.

Fix edge offset
add full snapping
add new mode axis constrain - extrude for direction global axis
add snapping for axis constrain
change dialog user


(obsurveyor) #136

Doesn’t seem to be quite there yet. Subdivided a cube twice and tried to extrude some edge quads and it’s fine going out of the cube but cutting in fails to either get the whole quad, or flips triangles and messes up.


(dpdp) #137

This is great. I’ve been doing a few simple extrudes with it and it seems to be working great so far. I contributed a little money on gumroad. When I use it on a paying job, I’ll give a bit more. I think this will save me a good bit of time on my archviz projects.


(atekdigital) #138

The new version 0.9 gave me the unexpected result. I have a default cube and subdivide few times and just with the spacebar search for destructive and everything disappear. The older version 0.8.9 was superb as expected it was. And the position of the addon was also good pressing alt+e it was quick to get. Now the position and the button lot confusion. This is the result for 0.9 new version http://pasteall.org/pic/index.php?id=119691


(Darcvizer) #139

@dpdp, thank you very much!

@obsurveyor, @atekdigital, I want to ask you to complete deestructive extrude not with the left mouse button, and click “Q” and send the scene to me, or you can see for yourself what is wrong and write here


(Darcvizer) #140

Using the standard blender settings, I can not repeat the result

on github update
script add in context menu alt+e