Destructive Extrude [BETA]


(Darcvizer) #141

Sorry, I made a ridiculous mistake when I edited the code on github… I fixed it and corrected the change of mode in the modifier when extrude on the axis.


(obsurveyor) #142

Thanks for adding it to Alt-E. It seems one of the addons I’m using now conflicts with Destructive Extrude. I reverted to factory settings temporarily and just enabled Destructive Extrude and it works just like your GIF.

I’ll try to figure out which one is the problem when I have a little more time to go through all my addons.

edit: Oh yeah, can you make it so escape aborts the Destructive Extrude? Currently it doesn’t do anything. Neither does enter or right-click.


(obsurveyor) #143

It would also be amazing if one day you could make it follow edges so it didn’t do stuff like:

And instead did:


(atekdigital) #144

No not again. Its not working perfect. What changes your doing i think .8.9 version is final perfect. look the result http://pasteall.org/pic/index.php?id=119708


(obsurveyor) #145

Mine was doing the exact same things until I went back to factory settings and then just enabled DE, it stopped after that until I went back to my regular config. We’ve probably both got the same addon enabled that is conflicting.


(Darcvizer) #146

@obsurveyor try return your settings but deleted all addons from addon folder
Maybe it’s in the settings and not the addons


(uruburei) #147

Deletes all settings and deactivates all addons. Nothing changed. When I make the extrude of central faces it works perfectly. But with side faces the addon does not work when it crosses through other faces


(obsurveyor) #148

I’ve reset everything in my Blender config(User prefs, addons and startup file) now with no change in behavior. I guess the times it actually worked for me were just luck because it will still eventually act like atekdigil’s GIF. I even deleted my entire 2.79 prefs folder from my user profile, extracted a new copy of 2.79 and put DE right in the addons folder and it still does the same thing. That’s as clean as you can get.


(Darcvizer) #149

oh…
Please send me a scene


(Darcvizer) #150

I do not know


(uruburei) #151

[video]https://imgur.com/a/0gUwS[/video]


(jachtarfranko) #152

The same as uruburei …


(uruburei) #153

and this another (blender-2.79.0-git.8d73ba5-windows64)


(Darcvizer) #154

you are not using the latest version.

If the disappearance continues, increase the distance. Line 202
Turn off and turn on the addon

Please send me .bend files.


(Darcvizer) #155


Fix auto merge
Fix reset transform
Fix swap offset beetwin union and difference mode
Use test distance = 0.2


(obsurveyor) #156

Still broken for me. Won’t extrude in or out, just does this:

http://nuclearfuzzgrunge.com/images/de-broke.blend

Switched back to tried and true Gumroad version from 9/5


(uruburei) #157

Sorry but don’t work

https://imgur.com/7Rjo8Wy
https://imgur.com/MbJFf8j


(Darcvizer) #158

Thanks guys for your help and patience.


(uruburei) #159

We are to be thanked for their work. Those who seek to make it easier to work on Blender are worthy of our applause. Thank you very much


(obsurveyor) #160

Yeah DE is awesome and I want to see it get better and help it get there if I can. Maybe we can hop in Skype or something early in the morning(for me) this weekend if it helps. Thanks for your work!