Destructive Extrude [BETA]


(Darcvizer) #161

Ok.
@obsurveyor what version of blender are you using? I was able to repeat your situation at 2.85


(obsurveyor) #162

2.79, latest release from blender.org downloads. It’s the portable version(not installed, just a zip)

https://i.imgur.com/dBUyvaF.png


(atekdigital) #163

Im getting this error. I have selected the loop and want to extrude below to have a groove.

Error

Blend file


(Darcvizer) #164

He swears at the fact that you have a polygon with an open edge


(atekdigital) #165

so what is the solution for that error


(Darcvizer) #166

Boolean modifier will not give the correct result if there are holes. And you in this case want to do boolean on the plane. So it is impossible to do…


(chafouin) #167

I really like your addon! I was wondering if it would be possible to keep the selection after the extrude? It could be an option is the user settings.

Also I’ve been trying to use bpy.ops.mesh.destructive_extrude() to call your add-on from one of my pie menu script, but it doesn’t work, do you have any idea?


(Darcvizer) #168

Such an idea was and I even began to implement it. But I have suspended the development of this addon. Perhaps I will continue in with exit 2. 8. Maybe there will correct the Boolean modifier…

You should not have any problems if you downloaded it from gumroad.
Try to write in the brackets ‘INVOKE_DEFAULT’

example bpy.ops.mesh.destructive_extrude(‘INVOKE_DEFAULT’)


(chafouin) #169

Works great, thanks!


(Iskander) #170

Hi Darcvizer, the idea of your add-on is revolutionary, and your demos look cool, but I use Blender 2.76 for Windows XP and neither Version 0.89 nor 0.9 of DestructiveExtrude. This is what I get -




В общем это печально, потому что идея замечательная. Думаю, проблема в версии Blender? Добавка не работает на версиях ниже 2.78? Или нужно что-то изменить в настройках?

THANK YOU for your creative initiative, patience and friendly attitude!


(Iskander) #171

Hi, I am sorry, it seems the forum refuses to publish my posts :)))

First, thank you for your add-on. Second, it doesn’t work for me. Using Blender version 2.76 for XP and getting these issues both with DestructiveExtrude versions 0.89 and 0.9:




Don’t know what to do. I was so excited with your demo…


(atekdigital) #172

A small problem arise with me. When push it down the face. It go fast like extrude or go fast below to cut of the face. I just want slow down i have used ctrl key also its not working for me. This is what i mean
http://pasteall.org/pic/index.php?id=123599

Im using blender 2.79 and version of addon is 0.8.9

How can i solve this issue


(Darcvizer) #173

Send me a scene please, I’ll try to figure it out.


(atekdigital) #174

file : http://pasteall.org/blend/index.php?id=48785

problem : http://pasteall.org/pic/index.php?id=123599


(Darcvizer) #175

Iskander
I’m sorry, I missed your message. The add-on will not work in versions before 2.78. Earlier versions do not have a CARVE motor in the BOOLEAN modifier


(atekdigital) #176

I have mention above that im usinge 2.79 and its not working as shown above


(sceyefeye) #177

I am guessing I missed a post earlier about my entire object disappearing with Alt-E Destructive Extrude. Not all the time, but some cases where I hold CTRL to snap and my mesh/object disappears. But cancel the command and there it is.

Not a show stopper, but obviously cannot snap to the mesh I am editing if I cannot see it

Otherwise awesome add-on - bought on gumroad


(Darcvizer) #178

Please make test


#179


It gave me this after tried to use it on an Inset on a square but then suddenly using it on just a simple face, it worked


There is a problem though, with using the 3D cursor as a point to extrude to, when using Lock to Cursor, some weird things happen lol

In this video you’ll see
[video]https://cdn.discordapp.com/attachments/296622315129536512/418147128242733058/2018-02-27_22-45-57.mp4[/video]


(Darcvizer) #180

ok, thank you