Did 2.35 change the UV texturing tools?

Look. I’ll be the first to admit that maybe I’m just a n00b or an idiot when it comes to Blender (although see here, I’ve at least been able to figure out poly modeling fairly well), but I just cannot get the UV editor to make any sense.

I’ve watched Greybeard’s tut, and read unwrapping Suzanne in the User’s Guide, and Modron’s Basic UV mapping and advanced UV mapping threads. And yet, I cannot seem to grok this.

I can only give a few examples, with no screens because I don’t have a host and you can’t upload here, but hopefully I can provide some context for my issues.

Looking at Greybeard’s video, and reading the related thread, I first attempted to texture by opening the UV editor next to my 3d window, setting up the seams for my model (I was fooling around with a UV sphere IIRC), then hitting U and selecting LSCM. So far, so good, right? Then I load my image in the UV editor (the same test map Greybeard used), enable the “TexFace” option in the Materials Editor, and . … nothing. No texture visible, in the 3d window or in test renders. Even when I add a texture to the material and have that texture load the test map, then have the texture mapped to the uv coordinates, no texture becomes visible (that’s with or without texface being on, BTW).

Another thing, you may have noticed that the WIP I showed on 3dbuzz had a texture in two of the screenies. I’ve at least managed to get a texture to display on a material in that instance (though I cannot say why it worked one time but not on the other, the only difference I can think of is I used ORCO for mapping instead of UVs, as this happened prior to my ill-fated attempt at UV mapping). Problem is, I could not get the model to have different materials applied to different faces. Based on the tuts, I thought that if you created, say, three materials, you could then select individual faces and apply the material you wanted to those specific faces. With the WIP mech, I could only get Blender to apply a material to the whole object, not individual faces. Working with the default Cube, I managed to get more than one material applied, but when I created my 2d and 3d materials the color of the 1st material changed when I edited the 2d, and the 2d changed when I edited the 3d. I never could get three distinct materials to display.

Is it just me, or did something change about the way texture editing works in 2.35? Are the tuts for 2.34 and pre-2.34 releases now obsolete? Or am I just dense somehow? Sad to say, I suspect the latter.

I’m hoping that I’ve conveyed my difficulty here, so that some of the very knowledgeable gurus can maybe help re-arrange my addled brain on this topic.

Mail your blend file to me at [email protected] and I will take a look at it. It’s really hard to tell what might be wrong from your description (sounds like you did everything right). There haven’t been any changes to UV mapping in the new release so the tutorials are still valid.



Thanks for helping out! I sent you two blend files.

The first one uses the test grid you employ in your LSCM video. I did the following: I opened the UV editor next to the 3d window; deleted the default cube; added a UVsphere with 32x32 segments; cut it into eight pieces with the seam marking tool; went into UV Face Select Mode; opened the test grid in the UV editor; selected all the faces in the 3d window; hit “U” and selected LSCM, which gave me a UV map on top of the test grid. I then created a new material with the sphere selected (which automatically assigns the material, AFAIK); added a texture to the material; mapped the texture to UV coordinates and used a spherical projection (in the texture options window, not in the UV editor); loaded the test grid into the “load file” window, hit “TexFace” and, voila … the sphere renders with no texture. Tweaking the material settings like specularity, hardness et cetera has an effect, but I cannot get the texture to show.I believe all of the settings are correct, yet the model will not
display the texture in the 3d window (object mode or edit mode), and will not render with the texture.

The second model uses all of the same settings, with only two things different. I saved the UV map as a .TGA and brought it into
Photoshop, then did a 2-minute texture, brought that into Blender as a JPEG, and loaded it as the image both in the UV editor window and in the texture’s file space itself. This model, oddly enough, renders with
the texture I imported.

I am really curious as to what the difference was here: is it simply that I need to save the UV map before it will render correctly?

The files haven’t arrived here :expressionless:

You could also try this address [email protected] although I doubt the problem was at my end.


(sorry for being off-topic…)

if you need an image host, i use this site

im terrible at UV mapping too, as i still haven’t quite grasped seams and LSCM…

oh well


Got your files :smiley:

The only thing that I could find wrong with the files was that you had “sphere” depressed instread of “flat” in the map input panel which caused the sphere to be rendered blackish. After setting to flat it rendered properly.

To make the texture visible in the 3d window you have to go into textured mode. The top button where you select wireframe, solid etc. in the 3d window header. You often have to tab into and out of edit mode for it to update in the display.

Note: you didn’t pack the textures with your files so I just loaded a testmap I had flying around (in the texture buttons I replaced your image). After making the above two changes everything functioned as in the tutorial.

As to why the second one rendered when the first one didn’t I can’t say because I didn’t have your textures.

Hope this helps,

Thanks for helping out. I’ll have to remember to choose “flat.”

Sorry about the textures, didn’t remember that they don’t get incorporated automatically into the blend file.