Did 2.83 change the hotkeys?

I have recently updated to 2.83 and although I like the new features I have had some frustrating problems.

The one I am currently baffled about is that some of the default blender right-click hotkeys are not working. I chose copy settings from 2.82 when I first opened it but hotkeys which were working then are not working now.

Examples are the merge which for me is now “m” instead of “alt+m”. Another one which I couldn’t find a solution for is hide tools in sculpt mode. “H”, which was previously used to make the hiding box, is now only controlling the visibility of face sets. I couldn’t find anything related to this online and the blender documentation still has “H” as the hide box tool, so I started to suspect that it might be a bug in the key mapping or something.

For people using 2.83 is this normal or you still have your old hotkeys working?

1 Like

Yeah probably no

“Alt+m” got changed a bit back. Can’t comment on the sculpt mode.

There is no sum-up of keymap changes.

In wiki, you can find, feature by feature, what is the shortcut associated to that new feature.
But there is no reminder of what shortcut was removed. And some changes has been forgotten.

Yes. It is normal that M is used for merged instead of alt m.
Yes. When H/alt H/shift H were chosen for Face Sets visibility, their previous use was left without new shortcuts.

That is a bummer. I think that there should have been a better way to tackle this, maybe some sort of a helper/instructor pop up that gives info about changes to previous default settings when a such setting is being used.

I guess I will have to change the keymap manually to how it was in 2.82 each time I sense something is wrong.

In 2.8 hotkeys to grab “scale move extrude” sometimes invoke corresponding “tool” instead of actualy “scaling grabing”. But tools dont have hotkeys, and i (as anyone else) dont ever need them. Has anyone experienced this problem? I cannot replicate this, happens occassionaly.

Maybe you press leader key / toolbar prompt on alt by accident?

You can disable that in window section of keymap preferences:

1 Like

Thank you, i will test this, so far seems all good!