Difference Boolean does not work

When I try to subtract the highlighted object (a rounded cube) from my custom mesh

I somehow just end up with a copy of the object I want cut out from my mesh.



Does anyone know why?
When I try to recreate the problem in a new file (subtract a rounded cube from a sphere) it works fine.

Here’s a copy of the file so you can try yourself. (I cut the object open so you can see what is going on)
DemoBlend.blend (628 KB)

Here’s a few things that could work

The boolean modifier prefers closed meshes.
It also dislikes double vertex
And checking the direction of your faces is relevant too.

why does you cube have so many verts ?

apply a dissolve limited

and it seems to work fine

also seems to work fine in latest build with all verts!

happy bl

Now I applied Limited Dissolve to the cube and inverted the cube’s face direction. When I now add the Boolean Modifier the cube gets cut out of the Main Object but the mesh gets all messed up

Here’s the blend file (this time the whole object)
DemoBlend.blend (634 KB)

that is normal for Boolean

did u try it in latest buildt should work better

if you want a cleaner mess it will be difficult
but you could try with knife project and again it will make tris!

happy bl

The main object is messed up before boolean. It’s also messed up after boolean because polygonal modeling is not done by extracting shapes out of other shapes.

Fixed the main object so that boolean works. It’s still horrible though
DemoBlend_ja12.blend (196 KB)

Thank you very much! Now I’ve got a new problem… But it also has to do with the Boolean Modifier.
I tried to remove a cube like that a sexond time and it worked fine. But the third time I tried it says “Cannot execute boolean operation”
I have no clue why… Could anyone help me?

EDIT: Nevermind, applying it still works

Thank you