different material colors for uv not showing


i assigned different faces of my model to different materials in the materials panel and changed the color of every material.

how can i make the uvs appear in the same color on the uv map so i have an easier time recognizing them in photoshop for texturing ?

Try unwrap on new image and Bake Textures. Usually Export UV Layout is used from UV editor menu. But if you want sort by certain material Bake Textures will help. It’s on Render tab, bottom part.

Use the Render / Bake / Textures option to bake the colour to an image
See: http://screencast.com/t/Oabw1evDrCy

thanks for the help. im trying to build a quality first person weapon model and tried smoothing the edges. it gave me a lot of headache with ngons and especially trouble with uv mapping, do you guys have suggestions how to make the model edges smooth manually ? im trying to make a cadian lasrifle so the gun is pretty uneven for extrusions so doing it manually to look smooth the same on all edges is kinda tricky…