different Materials like gold and glass in one?

I want to make a Shisha with some gold letters on it, but the rest should be glass. i´ve read some tutorials about glass, but i haven´t found a way to make a texture not reflecting and not shining through.
so the letters should stay solid and the rest should reflect and be transparent. but without any 3d work.
these col and cmir and alpha and so on buttons are difficult to understand. is there a tutorial about it? in german? that would be nice!

http://de.wikibooks.org/wiki/Blender_Dokumentation

And there especially:
http://de.wikibooks.org/wiki/Blender_Dokumentation:_Multimaterial
and
http://de.wikibooks.org/wiki/Blender_Dokumentation:_Map_To

i´ve visited wikipedia before, but i havnt seen, such good tutorial. thank you!

now with stencil the gold letters are right, but i want thick glass: and the standard technique with a blend:sphere texture, wich effects the alpha-value dont works correctly with something else than a sphere. what can i do?

I’m afraid I dont’t quite understand. You need raytracing for realistic glas.
http://de.wikibooks.org/wiki/Blender_Dokumentation:_Solide_und_hohle_Glasgegenstände

that dont helps me much. i´ve learned something, but the problem is:
every time I turn on RayTransp or ZTransp the gold letters get transparent. I never saw transparent gold in my life. did you? Is there a way to unlink textures from RayTransp, RayMirror and ZTransp? that would help!
I tried enviorment Mapping, but it dont looks like glass. there are refraction and a mirror-effect, but it looks crappy. if someone is interisted, i can mail him the image.
another problem with env: because i have to hide the object (shisha) in a layer this env-map-texture dont renders, the letters on the back are missing. i understood, why i have to hide the object, but this dont solve the problem.

here is an example for a shisha:
http://www.drogenwiki.de/wiki/images/7/7d/Shisha.JPG

I’m assuming that you have the letters as a texture.
On the material settings, select the letter texture, and then press ‘Alpha’ (once) under the ‘Map To’ settings. Hopefully that should help - if not then post the .blend file and hopefully we can help better!

This time a tutorial in english:

http://mediawiki.blender.org/index.php/Tutorials/Textures/Use_Alpha_for_Object_Transparency

You could use the “Material Settings 2”.

i had some work for school.
my problem isnt solved and its important so check the link with the .blend

http://rapidshare.de/files/10925812/shishasmall.blend.html

click in the table on free. scroll down. wait until the seconds have passed by. type in the letters on go!

i am sorry i havnt found a better webspace.

A couple of things:
Make sure you press ‘Pack’ in the File menu, so that the image files etc that you are using are put in the file - can you do this and reupload it?
Also, why are you bothering with envmaps? Just use ray transparency and ray mirror.

I’ve fixed the file, but I need your E-Mail address to send it to you.