Different shadings on model. How to fix this?

Is it because of vertices too close to each other or something? I really can’t understand why this is happening. Neither do I know how to fix this. :frowning: Any help appreciated!

Do you have any materials on your object? It seems you are going into rendered mode, so that would require both lights and materials to look correct. Some more info would be great on what the problem is (in final render is it the same, is the problem with materials, etc.)


Here is my blend file. A part of the model.

logi_350_part.blend (549 KB)

I don’t see the problem? The first image you show is one where solid shading is on with matcap, second image is a viewport render of your model and then you show the wireframe view? And those look normal to me… I looked at your blend file, its part of the keyboard mesh with 3 materials applied to it. You should turn on "use nodes: if you want to further customize your materials though.

Yea, but why are they in different shading? Darker on some parts of the mesh. Even if I move a light to shine on those dark parts, they are still dark. I don’t understand why. =/

The solid shading with matcap enabled, lights dont affect that. The viewport render you did if you move the light around it won’t change the shading because its a sun lamp, it will light the scene differently when you rotate it though…

Alright, thanks! I did try to light this side with a plane as emission, but that spot still hasn’t got equal shading. It seems whatever I do, that spot can’t have the same shading. It looks really weird. :frowning: