Difficulties inserting movies into the sequencer

I recently tried to insert a video file into the blender sequencer, only to get the error message

The selected file is not a movie or FFMPEG-support not compiled in!
The file in question was an AVI file re-encoded from MPEG using MediaCoder. The AVI was 19MB in size, from a MPEG 99MB in size.

I am running Blender 2.42 on Windows XP Professional.

Other files, not encoded in the same way, could be inserted in the sequencer. In addition, it was possible to play the file in Windows Media Player.

What can I do to allow me to insert the file?

AVI codecs in windows, indeed in any OS, is a most frustrating issue. They exist somewhere as OS add’ons. It is best to use something maybe like Windows Movie Maker to save it as uncompressed, get it into blender, and then re’export it. That way, you know that blender + codec + file + OS equals success. Frame sequences of jpg or png or tga or exrs always work.

2.42a does not support mpeg import/export.

However the windows CVS version does, you can get it here :



Thanks, I’ll try re-exporting it uncompressed and see if that helps.

Mike_S: Does it still not work if the MPEG was re-encoded as an AVI? I don’t know a lot about AVIs, so is an AVI just compressing an existing file(s), and still having the problems of the original?

Thanks for the CVS link, I’ll try that as well.

just wrote this up. Be sure you are left-clicking on the movie name. see http://mediawiki.blender.org/index.php/Manual/Using_VSE#Add_Movie_and_Image_.28Stills_or_Sequences.29
AndyD had this issue and reading it finally cleared it up for the little purple martian dude with the kool sunglasses.