Difficulties with .M3 importer

Hello, I posted this on the Blender forums, but I got no answer, so I’m going to try here. Here’s the link: http://www.blender.org/forum/viewtopic.php?t=20298 Thanks for your help!

Help? Anyone?

You say

When I reopened Blender and clicked File>import, I did not see any change from before extracting the python files, and no .M3 option is available

Does that mean there was no option in the Import menu for .M3 files. Did you activate the importer script in the File / User Preferences / Addons panel. The link to the importer wiki entry says its for blender 2.56a. If this is correct and it hasn’t been updated for blender 2.57 it may not work.

Hello Richard, thank you for you reply. I did try to add it through the user pref’s add-on menu, but it wasn’t on the list of add-ons. So I tried to install it by pressing the button “install add-on” and selecting the each of the .py files in turn, but it didn’t do anything, they were still not on the list of add-ons, and of course, not in the import menu. So do you think I should uninstall Blender 2.57 and install Blender 2.56? Is it available somewhere on the net? Thanks again.

Blender 2.56 http://download.blender.org/release/Blender2.56abeta/
Remember this is beta software so be warned it may crash and there are no guarantees that anything you make with it will be compatible with any other blender version.

This is such a catch-22. I hope the developer of the .M3 script will update the add-on, or someone else will create something similar… I try the 2.56 version and will come back to report.

OK, I downgraded to 2.56 and now the script works, it’s not perfect, but still very impressive. Thanks for the help!