Dinosaur Finger Bone Rigging Problem

Hello! I’ve being at this for a while now and finally decided to turn to this forum for help.

I have a dinosaur here I’ve rigged for animation, all the bones are working fine, except for the fingers (minus the middle finger) as you can see it moves fine on it’s own.

But it’s a different story for the other fingers. If I move either the left or the right finger it severely distorts the finger on the opposite side. I’ve done all the bone naming correctly as far as I can tell (midpalm.L, midpalm.R etc) but still responds as such, I don’t know if it’s another issue I’m having.

I would greatly appreciate any help to get this sorted -Gemma

Hard to tell by looking at the pictures. Did you check the weights?

Yeah, I bet that if you go into Weight Paint mode and toggle through your bones in the Data menu (the button with the triangle) You will see that some of the weight from the bones is bleeding into the surrounding fingers.

Those claws remind me of Therizinosaurus.

Ah I see the problem, have another one though, the weight paints are reacting to the same fingers I mentioned in the pic (paint on the left hand, does the same with the right). I might have to delete these bones and re-parent them to see if it makes a difference.

Could it be that x symmetry was turned on when weight painting for that bone? I manage to do that sometimes.

Fixing weights via weight painting is actually quick once you figure out where the settings are, though I know many artists avoid it.
Set the vertex masking so you can see which verts are affected by each bone, click on each bone group in vertex groups, hit ‘select’ and look to see what lit up. Then select each vert that shouldn’t have, looking at the weights in the property (n-panel) panel, and delete the bone groups that shouldn’t be affecting that vert, normalizing as you go.
If there are too many verts to fix one at a time, then paint with Subtract brush set to 100%, then clean each vertex group (weight painting tools), checking with 'Select" in vertex groups tab, as you go.
I know it makes for a cluttered workspace, with the tool shelf, properties panel, vertex groups all open as well as 3D view, one’s eyes popping back and forth like a ping pong game. But automatic weighting can’t and won’t work perfectly for verts that are any distance from the bones, as the ends of your dino fingers are.

How would you turn off the x symmetry?

Because it is a Therizionsaurus :slight_smile: Thanks for your advice!

I can do all this, trouble is it’s affecting each side of the bone (the right hand finger will do the same for the left hand finger) I think I’m going to have to delete the bone extrusion for the fingers and do them separately if I can’t figure it out soon. Thanks for your help :slight_smile:

Do you have right finger weights on the left finger or vice versa? I think that’s my question, as it sounds as though you do. Happens all the time depending on what one does and in which order.

In 2.79 at least, toolbar/options/x mirror.

Any problems here could probably be solved pretty quickly if you linked a file, but otherwise it’s just a guessing game.

I’ts in the active tool settings -

I’m using blender 2.79 and can’t seem to find the symmetry, so far no luck, here’s a copy of the file I’m using. Theriz9.blend (715.9 KB)

attached some shots, it’s under options/x mirror - you had the weights mirrored by accident. attached a blend file as well, should be fixed now. (I think, I’m on a tiny laptop atm so I’m a bit clumsy)

52%20PM 09%20PM Theriz9.blend (719.8 KB)

ah I was looking in the wrong spot! Thanks so much for your help you’ve solved my problem with that, can’t thank you enough, will remember in future :smiley:

1 Like

haha, don’t mention it :smiley: glad I could help

1 Like