DirectX Exporter Updated


(Ben) #1

-Hi
-I have updated my DirectX Exporter(export in DirectX file format)
-I’ve added a module that exports object animations.

www.benomari.too.it

There’s a link in the home page or in Tutorials section.

Thanx


(Rob) #2

Really interesting page, thanks.

Please can you give some explaination of the uses of directX export.
In games that support directX?

Rob.


(Ben) #3

-The directX export,exports files in the .x file format.There are four modules to be installed in the python path(Python\Lib) or in the blender
folder you are using.Then open the blend file and press Alt-P.You 'll see
four buttons that exports the blender scene(you create or append)
1-exports only a normal mesh
2-exports a normal triangulated mesh
3-mesh and texture
4-mesh and the object animation
every button will export a different file with .x extension that can be used
in the directX games.DirectX knows directly the animation in the .x file.So it can be used without other transformation in the game.Soon will come a mesh+texture-animation exporter and I’ll try to make a better help file.


(blender_man) #4

Hi, great utility really useful coz i’m trying to use models from Blender in Darkbasic the only problem is that i can’t seem to get animations to work?? It may just be me and the way i’m adding the files in darkbasic but i’ve got no way of checkin.

Any ideas about why its not working??
Anoyne know a directx viewer so i can find out if the file is O.K or not??

Any help would be really great!!
thanx :smiley:


(Ben) #5

Hi
-The 3d viewer I used to test DirectX exporter is 3D Exploration

www.xdsoft.com/explorer (it’s shareware but ensure you it’s the best)

You can view 3d models and animation


(blender_man) #6

Great download it works great but my animation still doesn’t work their’s the model and all the frames that i speciffied but each frame is exactly the same!?!

It’s a relative key vertex animation on a subdivided mesh.

Any ideas???

Thanx


(Ben) #7

-The DirectX exporter exports only object animation(means position,rotation and size) not mesh animation.In the DirectX format
there is no information for the vertex animations.


([DiE]) #8

I was told you could do vertext animations. Yet I am still stumped as to how to get at the necessary information. Here is a link to my script. If anyone that has done it knows a solution how about being cool and listing it on here. I did find you can export one frame at the time and get a pretty decent animation. Its a pain but the only solution I know. Writing the c-code for it is pretty simple, and I can recombine them into one Frame object in my program.

Also I’m still working on a 3D animation modeler to work in conjunction with Blender. I was hoping I wouldn’t have to write it so I could devote all my time to my game but it looks like I’m back to working on it again…

anyhow, peace…

http://www.pimpworks.org/~squirrl/ascii.zip

short run down of what it does.
dumps vertices/faces/UV coordiantes to a text file
as well
dumps a texture filename


(Squee) #9

I tried to use your Direct x exporter but I just get a error that say’s “Import error no module named string”. I really have no idea what that means as I have almost no past experience with Python. Do you have any idea why it is doing this?


(Schlops) #10

Squee, you need to install Python and set some environment-variables, take a look here: http://www.janw.gothere.uk.com/pythoninstall.html


(theeth) #11

Or, you could just instal the string module from someone.

Martin


(dwmitch) #12

Hugs Ben Thank you!!! You saved me a lot of work!

Wait a minute…
Did I just hug a guy?
shudders


(beatabix) #13

SQUEE!

oh my god! a JTHM fan! whoopeeee!!!
“did you hear that, shmee?”

BEAT


(Squee) #14

Thanks for the help people. I forgot I had not set up the Py Path when I installed python. I guess that is what happens when I get lazy.
Also JTHM rules I’m glad to find other fans.


(Squee) #15

I finally set up my Py path but it still gives me the same error.
I have already double checked the path so I know it is set up right.
Do you guys have any other ideas?


(theeth) #16

at the top of the script, try adding:


import sys
sys.path.append("c:/python20/lib")

of course, replace “c:/python20/lib” by the correct path to the Lib Pyton folder on your system.

Martin


(Ben) #17

-Copy the string.py module from Python\Lib(supose it’s there) and paste it in the Blender folder you are using.


(Squee) #18

Well thank you all I have now got it to work. unfortunately
I have run in to another problem. When I use the texturex
module it does not produce an object in the .x file. I am loading
it with 3D Exploration. 3D E says that there are about twice as
many vertexes as there should be but no faces. All the other
modules work so I have no idea what’s wrong.


(Ben) #19

-I dont know what can be wrong.If you give me an e-mail adress
i’ll send the textureX module separately.So you can load it in Blender
and run with alt-P.Maybe it works better this way.
Ben


(Squee) #20

It’s my object i just tried it with a normal UVsphere and I worked fine.
The object that I was using before was a tree I made from a plane.
I still need to convert the tree so do you have any idea what could
be wrong with my object?