Disable a joystick for Yo Frankie!

Hello all!
I’m new here and have used Blender as a hobby for about a year now. I’m trying to play Yo Frankie on my mac book pro, but for some reason it keeps telling me a joystick is connected (which isn’t) so I still haven’t been able to play it! I read somewhere that someone “ran blender with ‘-nojoystick’ and it worked.” I’m not exactly sure what that means or what to do (or where to do it) in order to ensure the game doesn’t check for a joystick connection…

For all I know this is a very noob question with a simple solution, but I really want to play the game so thanks in advance for any help!!! :smiley:

I’m used to windows, wherein you can use the dos prompt to use the command you mentioned- but as far as I can tell, terminal (the mac equivalent to the command line) doesn’t allow applications to be launched with parameters.

[edit] ah, I think I figured it out- as far as I can tell, you have to launch the actual application, while what you normally see as Blender is a folder. This means you have to open Terminal.app and type

 /path/to/blender/blender.app/Contents/MacOS/blender -nojoystick 

So on my computer, where Blender is in /Applications/blender, the command would look like

/Applications/blender/blender.app/Contents/MacOS/blender -nojoystick

From there, you should be able to open Yofrankie in blender like normal, and then press P to play like normal.

Please excuse me if I made any errors in the above.

Worked like a charm, thank you!