Disable Eevee?

Is it possibly to disable entirely Eevee from Blender (until manually reactivated)?

While working on procedural material heavy scenes, it happens to me sometimes to activate Eevee rendering by mistake, often by mis-clicking on the shading pie triggering the calculation of all shaders in the scene, causing Blender to hang, and since I rarely use Eevee anyway, I could use a way to disable it.

Any suggestion? Thanks!

… you can just change your rendering engine to Cycles:


If you do this, you won’t have to worry about Eevee, since it won’t be used at all in any context by Blender

I would try going into the material editor and create 2 material outputs, one for each renderer. You then plug the complex procedural shader in the Cycles output and give Eevee a harmless diffuse bsdf with no texture.

1 Like

Actually if you set it to cycles material preview (3rd shading ball) will still use eve (including it’s render properties). If you set it to workbench, then it gets rid of both eve and cycles so you only have copy of solid mode with duplicated settings as render.

2 Likes

No, the shading pie setting disregards the Eevee / Cycles selection

@etn249 thanks, but that’s a bit convoluted; this being a asset collecting scene, beside having to open and edit each material, I also need to have cleanish materials at the end of the work.

@Format64 thanks! it’s not ideal, but it’s a very good stopgap

1 Like