Disable IK tweak stretching?

Hey, I am having problems with the arms and legs of my character.
I have disabled IK stretching in the rigify options menu, for the IK controls (red) on each foot and hand. However, I cannot find a similar option for the tweaks (the blue spheres in the knees and elbow), and since moving the red IK targets often makes the bones bend the wrong way, I have to move these correspondingly.

The problem is that this easily messes up your bones with stretching and wrong proportions. Any not-too-complicated solutions? I am relatively new to blender.
Thank you.