disable mesh light shadow

Hello. how do i prevent a mesh light from casting an objects shadow in cycles? Thanks.

Moved from “Basics & Interface” to “Lighting and Rendering”

you can go to the object’s(the one casting the shadow) properties and under ‘ray visibility’ uncheck diffuse


I would like to be able to have some mesh lights cast shadows while others do not.

can’t be done per mesh light I guess

but you could replace the mesh lights with area lights wherever you need shadows

and if you don’t want to replace with area lights you could make a copy of the scene and combine the results in comp…

see how it goes

Thanks Dileep.