Disable setting keyframes for locked transforms

Hi there,

I have an armature and there are bones with some locked transforms. For example scale xy and rotation xz is locked. Adding keyframes with LokRotScale sets also keyframes for locked transformations which is in my opinion useless and makes the graph editor disarranged. Is there a way to disable setting keyframes for locked transforms?

Or is there a way to remove keyframes for locked transformations?

You can use the “available” keying set.

Short but really helpful… thank you Hadriscus!