Disappointed in Blender's edit mode performance.

No, this has nothing to do with outline selected, or other viewport overlays in regards to edit mode. Edit mode is just very, very slow compared to object mode.

But yes, outlines still dramatically affect object mode (which is a tad ridiculous at this point). For example, a 5.1 million vertices scene runs at 27fps on my system. 18 objects in total. Selecting all objects with outlines turned on causes a drop of FPS to a sad 9~10 fps.

I wish the devs would focus a little bit more on ironing out these viewport issues. I sincerely hope things will improve soon, or Blender will become somewhat unworkable for me.

“which is a tad ridiculous at this point” - why? Outline is calculated taking in account all underlying mesh so imho there is not much difference if you have to calculate/draw e.g. 40% visible, not occluded mesh edges or just an outline - you still need to calc what’s occluded to get to this.

If triangulation and BVH calculations are left on a CPU- get better core count (if there is a multithreading taking place, i hope there is) and up the freqs. You’d need to deal with 6.5 millon faces and cherry pick part of 11.5 million edges for each frame as in above example file.

They are. It’s partially the reason for all of the OpenGL updates planned for upcoming versions of Blender. Of course, since OpenGL touches virtually every aspect of Blender’s display code, this has been (and will continue to be) a time-consuming process.

I wouldn’t expect any marked performance increases until 2.8 and after.

Agreed. This is actually a real problem. Blender should concern about this as high poly editing is kind of impossible in Blender. Didn’t notice earlier. But now after trying to make a decent high poly hand-watch I am seeing a huge lag too. :confused:

Agreed. I hope they are really gonna improve this. Importing a tree with ~1.400.000 vertices makes the programm almost or pretty much unusable in edit mode. The feature set of Blender is nice, but this performance issues is starting to get more and more apparent.

Work on rewriting the OpenGL code is already underway in the 2.8 branch (and a recent Sunday Meeting has the developer hinting at the code being ready for tests sometime soon).

All we can do is wait as of now, but please note that the developers are indeed aware of Blender’s OpenGL being archaic as shown by the project.

Hey there guys, honestly using the Shift - H method to hide everything but what is selected in editing mode gives me fantastic fps to do work on high poly stuff. Hope that helps everyone just a bit.


It doesn’t if you need to evaluate your mesy constantly in seeing its entirety, also I"m a tad worried, tho this thread may no longer be the 'go to 'thread for this issue, but if ACe’s post is relevant and no other, anywhere, this 3 yrs later to still have issues, and actually edit mode is now worse, than it was even a few weeks ago, I have to wonder what dev. is really doing.

We all have to make the best of what we have to work with , fix, add new features but this lacking or incorrect roadmap is seems it may be giving many reasons to flee.

Any recent update regarding this since the issue is still there?


Nov 2011

Found a fix with my laptop : set the power manager to keep the - minimum processor load to 90% - maximum processor load to 90% and this gives 2x boost to my viewport experience. From 10 fps to 24 fps back in. 90% means that the CPU will stay at 1.72 ghz all time with any app.

Same power setting gives double fps in games. So low performance can be due the power management setting that will not kick in if CPU is used at 10% that was happening in some games and blender for me.

Warning check the temperatures and use what it fits your cooling on the laptop. I can get maxim 88-90 C ...full performance at 2.7 ghz is 95-100 C turbo going down for cooling.

OpenGL performance it is dependent on CPU and GPU.

Without the top settings normal usage :
-Team Fortress full usage full server 24 players max 30 fps dropping to 20 , Blender medium model 11 fps
With the settings :
-Team fortress 60 fps and idle 120 fps , blender medium model 24 fps

At full power 2.7 ghz turbo boost the sums are up more but that is to risky.

*:slight_smile: I keep two settings : drawing - and surfing the web - chatting 960 MHz , blender - games 1.7 ghz (factory freq). *and when needed rarely to 2.7 ghz for rendering * with added cooling station.

This is for Core i7 and it is valid even for Nvidia and AMD video cards.

this post is dated Nov 2011

Any fix done for 2.90 ?


1 Like

+1, I’d love to see a fix for this, been going on too long now :wink: