Displacement issues

Hi all,

I’m kind of a noob at this so bare with me.
I keep consistently running into this problem where displacement just blows up my whole mesh and I just can’t figure out why it keeps happening. I tried setting the displacement node to object space, though world space isn’t doing anything different either to it. It just doesn’t want to displace from the surface normal.

Any help is super welcome

Thanks!

You’re node setup is too small for me to read. Can you zoom in a little?

Also - are you using a displacement mod or micro-displacement?

I’m guessing you’re plugging directly into the material displacement. You need to run through a displacement node (Add -> Vector -> Displacement), like so:

2 Likes

microdisplacement, the Experimental features are selected in the rendering window and the subdivision modifier is set to adaptive.

I tried the displacement node, it still offsets it diagonally and doesn’t take the normals into consideration

Did you plug the color output of your texture into the normal input of your displacement node? What you discribe happens if you do that.
The Fac output should be going into the heitght input like in the image posted by tomjk.

1 Like