displacement map bug in 2.5

I’m using the material nodes and i’m trying to mix between two materials, using a matte as the factor. one with a displacement map and one without. for some reason the matte i have for the materials doesn’t work with displacement checked but it does with everything else.

I am using blender 2.56

upload thei file so we can look at it and some pic may be !

happy 2.5

Hi,

I am not sure if this is related but there is a post on blenders bug tracker may explain why:

http://projects.blender.org/tracker/?group_id=9&atid=498&func=detail&aid=26011

Again not sure if they are related or not.

This should make things a more clear.
Notice how the image with the normal map is not covering the whole model, the material node is working. But the image with the displacement map on the model covers the whole model, the matte isn’t working on the material node.
I think there is a bug.




Material node setup with normal map with displacement

Hi,

I tried mimicking your file with a simple setup and it seemed to work for me. I didn’t use a material for the factor texture though I just used a blend texture.

I have attached the blend file.

One thing I did notice is that the transition between the mask having an effect and it not is very small. So a blend texture that gradually changes for normals display seem to have an effect but sharpening up the mask transition seems to work. As demonstrated in the blend file.

It has 3 materials. 1 a red material that has no bump on it. 2 a yellow material that has a bump on it. 3 is a node material that combines materials 1 and 2 onto a 3rd sphere which is half of the first material and half of the second. The mask into the factor is just a simple blend texture.

Also attached is a render of the result.

I am running a very recent version of Blender 2.56 from graphicall.org so it could be important.

Attachments

Bumpy - Spheres.blend (120 KB)


Hi,

Did some more experimenting this time I used a material as the mask. And as a result had the problem you do. But I think I found out why.

If you render the attached file. The sphere on the lower left hand corner of the render is my mask material. You will notice that it is grey and dark in parts, but its never pure white. This is despite the fact I set its material to pure while and I put its intensity to 1 as well.

If this material is used as a mask its very near 50% gray (as you can see from the render) which is going to mean that it will when used for mixing mask basically mix the bump and nonbump materials such that they will be a 50% blend. And in your case that would mean the bump ends up all over your output material.

If you click the lower left Mask material and really crank up the material color (rgb 4 or 5 even though rgb values seem to be limited to a max value of 1 if you type in values directly they can go above 1) and then render you will notice it takes more and more effect as it gets nearer to brighter white. Using shadeless does similar things.

So I guess a good test would be for you to render your mask and see what it looks like, if its not near white or black in the parts you need it to be but instead near a gray color that could be why.

The material nodes send the results of shading to mask as a result it doesn’t work as expected.

Attachments

Bumpy - Spheres - Gray Mask.blend (148 KB)


@ AIBlender it’s not the bump map that’s the problem. Bump map works fine. It’s the displcement that ignores the mask. I think there is a bug with displacement.

Hi,

Yep same result here displacement doesn’t work. Attached is a blend file I tested with.

Attachments


Displace - Spheres - Gray Mask.blend (601 KB)

You can create a displacement map using texture nodes without using any material nodes.

ok this work well with procedural texture

but what happen if you begin with a black and white bump image map
how can you work with this in 2.5 and get good result if possible

and i eman whithout working with UV and alpha map
which i already seen in Blenderguru tut

Could you get around the problem by jsut making a yellow material and then applying the displacement map as a texture, and going without the nodes? That’s what I did for this scene I made just to test displacement maps…


Sure it’s a UV, but it worked, and this would be good as a procedural thing, because as it stands, your image looks like it’s projected.

Plus the problem that you have been running into has been around for a while I believe, because I remember another user and I trying to solve the same problem, although he came up with a solution that was a bit more difficult than it should have been to get a good result. I don’t know if I still have the file though.