Displacement mapping: almost there, but not quite

I’m using displacement maps to create the “X” you see on the cylinder.

I’m trying to get rid of the jaggies you see in the render below. I already have a ton of geometry as well as my Subsurf at level 5. Doesn’t seem to help.


What am I doing wrong?

As I can’t see you base object’s geometry I suggest that in the first place you subdivide the base geometry a bit more. Then apply the displacement and afterwards apply a subsurf (level 2 or 3 should be sufficient).

Please find attached a .blend file where I reused your texture. I used the displacement modifier to apply the displacement.


displaceTex.blend (243 KB)

WOW, that looks amazing. Thanks for the help.

I thought I had subdivided it a lot already, but let me download your file and see how you do it.

Thanks again for the response, I really appreciate the help! :smiley:

tp use displa it may help to blur your original image in gimp
this will help to have rounder edges

cause if you don’t edge are going to be very big and not nice to look at
so by using a blurred image it will limit this problem

the displas modifier is easier to control then the ordinary displa in F5

hope it helps

It look me a little while to figure out what is going wrong but think I might have found the problem. It seems that you have not properly uv-mapped your cylinder.

If you just use the “unwrap” option without either settings seems before or using e. g. “cylinder from view” projection I manage to get the same result as you have. I attached a .blend file to illustrate that.

So I think the solution to your problem is a reasonably uv-mapped cylinder (my cylinder is uv-mapped; just go into edit mode and open an image editor window to see the mapping; however be aware that my mapping is quick and dirty and anything but proper… :o ).


displaceTex_2.blend (214 KB)