Displacement problem

Hi everyone,
I’m trying to add a decoration to the top of my lamp using a displacement node.
As you can see, nothing shows up rather than a pixelated texture.
I tried the same exact nodes on a low poly sphere and all goes well.
Can you help me?

You’re in Eevee.

No, I’m in Cycles

Material preview mode is Eevee.

Even when you have selected the cycles renderer in the Render Properties.
the Material View is always a dev look/Eevee.
and you need to select the cycles(fourth button) to really preview in cycles.

and in the renderer properties you can adjust the sampling for viewport to work efficiently real-time.

even if I do as you suggested, the displacement node does nothing

Maybe because you have no texture coordinate node.

check the uv map of the model.
if it is alright then, use
Texture Coordinate to plug in the UV or object, depend on how you are using it.

to test this material.
add a new plane. and see if displacement works

1 Like

how it normally would show


and how it would show after displacement

making a plane and testing the material there is a better way and then move to complex shapes

Have you check this?

image

Also is there enough subdivision for the displacement?

1 Like

yes, tried, but it does nothing usefull

Is the model UV unwrapped? If so, plugging in a texture coordinates node should do the trick.

Also, a scale of 8 is insane (considering your grid.) Also, sRGB is unlikely to be the proper mode for your image.

But starting from zero here, there are so many things wrong, without a lot of information in response to concerns about them.

Fix everything mentioned, then upload a file, and people will fix the problem in 2 seconds flat.

1 Like