Displacement shader not displacing geometry

When I use a displacement node in Cycles, I only get a bump effect. There’s no geometry displacement, although I do have it set to displace in the shader settings. Can someone explain what I could be doing wrong? I’m using the SubD modifier to get the required polygons for the displacement.

Can you upload Blend file exemple ?


That got it…thanks.

I’ve run into a few things in Blender which annoyingly need to be turned on to make something work the way you think it would work out of the box. Digging around inside the software to make something as simple as displacement work is probably something the devs should take a look at. It should be on by default.

Nice to hear that it was that :wink:

Save your startup file with that setting on, so that every time you start Blender you don’t need to change it.
It woun’t change the settings of your old files so you need to do the change for those, but new files will have it on.

Glad this was asked because I had the same question. Cycles now working - can Eevee do the same?

Nope. You must use displacement modifier instead.

The reason it isn’t on by deafult is that were hundred of bug reports because users were using it as a bump in eevee (with 100 times the distance they should be using) and when they swithced to cycles the displacement caused them to cry for help.